aboutsummaryrefslogtreecommitdiff
path: root/apps/dma1/CMakeLists.txt
diff options
context:
space:
mode:
authorTrygve Laugstøl <trygvis@inamo.no>2017-01-25 22:33:54 +0100
committerTrygve Laugstøl <trygvis@inamo.no>2017-01-25 22:33:54 +0100
commit99faf57b4296b032e486cbf3829745cbcb14a80b (patch)
tree85ad7541a4e7aef2a5ffa9eef91b3b26100ed2f8 /apps/dma1/CMakeLists.txt
parent40e04e3772726829d66c12e69f24b03920d79c67 (diff)
downloadstm32f103-playground-99faf57b4296b032e486cbf3829745cbcb14a80b.tar.gz
stm32f103-playground-99faf57b4296b032e486cbf3829745cbcb14a80b.tar.bz2
stm32f103-playground-99faf57b4296b032e486cbf3829745cbcb14a80b.tar.xz
stm32f103-playground-99faf57b4296b032e486cbf3829745cbcb14a80b.zip
o Using upstream's tinyprintf which requires 64-bit math operations, so add gcc as a required library.HEADmaster
Diffstat (limited to 'apps/dma1/CMakeLists.txt')
-rw-r--r--apps/dma1/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/apps/dma1/CMakeLists.txt b/apps/dma1/CMakeLists.txt
index 19321d8..008982d 100644
--- a/apps/dma1/CMakeLists.txt
+++ b/apps/dma1/CMakeLists.txt
@@ -13,7 +13,7 @@ target_include_directories(dma1.elf PUBLIC
$<TARGET_PROPERTY:playground,INTERFACE_INCLUDE_DIRECTORIES>
)
target_compile_definitions(dma1.elf PUBLIC ${DEFINES_FROM_MCU_STM32})
-target_link_libraries(dma1.elf tinyprintf)
+target_link_libraries(dma1.elf tinyprintf gcc)
target_link_libraries(dma1.elf dma1-mcu-stm32)
set_target_properties(dma1.elf PROPERTIES LINK_FLAGS "-nostartfiles -T${CMAKE_SOURCE_DIR}/cmake/stm32.ld")