aboutsummaryrefslogtreecommitdiff
path: root/apps/usb1/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'apps/usb1/CMakeLists.txt')
-rw-r--r--apps/usb1/CMakeLists.txt20
1 files changed, 20 insertions, 0 deletions
diff --git a/apps/usb1/CMakeLists.txt b/apps/usb1/CMakeLists.txt
new file mode 100644
index 0000000..568aff7
--- /dev/null
+++ b/apps/usb1/CMakeLists.txt
@@ -0,0 +1,20 @@
+mcu_stm32_add_library(TARGET usb1-mcu-stm32
+ DEVICE STM32F10X_MD
+ PARTS RCC SPI GPIO DMA USART
+ DEFINES_VAR DEFINES_FROM_MCU_STM32)
+
+add_executable(usb1.elf usb1.cpp
+ ${PLAYGROUND_DIR}/src/init_low.s ${PLAYGROUND_DIR}/src/init_high.cpp ${PLAYGROUND_DIR}/include/init_high.h
+ ${PLAYGROUND_DIR}/include/playground.h
+ ${PLAYGROUND_DIR}/src/debug.cpp ${PLAYGROUND_DIR}/include/debug.h
+ )
+
+target_include_directories(usb1.elf PUBLIC
+ $<TARGET_PROPERTY:playground,INTERFACE_INCLUDE_DIRECTORIES>
+ )
+target_compile_definitions(usb1.elf PUBLIC ${DEFINES_FROM_MCU_STM32})
+target_link_libraries(usb1.elf tinyprintf)
+target_link_libraries(usb1.elf usb1-mcu-stm32)
+
+set_target_properties(usb1.elf PROPERTIES LINK_FLAGS "-nostartfiles -T${CMAKE_SOURCE_DIR}/cmake/stm32.ld")
+add_extra_commands(usb1.elf)