summaryrefslogtreecommitdiff
path: root/cmake/elfinfo/CMakeLists.txt
diff options
context:
space:
mode:
authorTrygve Laugstøl <trygvis@inamo.no>2016-07-01 22:57:09 +0200
committerTrygve Laugstøl <trygvis@inamo.no>2016-07-01 22:57:09 +0200
commitc09d293d2b34d15e8bf609466d55555c74587845 (patch)
treeeebf4c9db5d0809cd2ba35ef7d7660bc3c66fbd7 /cmake/elfinfo/CMakeLists.txt
parent3bf71c66f63f33471b172570a3a20710d6fe6b72 (diff)
downloadintel-quark-d2000-playground-c09d293d2b34d15e8bf609466d55555c74587845.tar.gz
intel-quark-d2000-playground-c09d293d2b34d15e8bf609466d55555c74587845.tar.bz2
intel-quark-d2000-playground-c09d293d2b34d15e8bf609466d55555c74587845.tar.xz
intel-quark-d2000-playground-c09d293d2b34d15e8bf609466d55555c74587845.zip
o Adding elfinfo tool from the stm32 playground.
Diffstat (limited to 'cmake/elfinfo/CMakeLists.txt')
-rw-r--r--cmake/elfinfo/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/cmake/elfinfo/CMakeLists.txt b/cmake/elfinfo/CMakeLists.txt
new file mode 100644
index 0000000..82efcdf
--- /dev/null
+++ b/cmake/elfinfo/CMakeLists.txt
@@ -0,0 +1,13 @@
+cmake_minimum_required(VERSION 3.2)
+
+project(elfinfo CXX ASM)
+
+add_executable(elfinfo elfinfo.cpp)
+target_compile_options(elfinfo PUBLIC "--std=c++14")
+target_link_libraries(elfinfo elf)
+
+INSTALL(TARGETS elfinfo
+ RUNTIME DESTINATION bin
+ LIBRARY DESTINATION lib
+ ARCHIVE DESTINATION lib
+)