aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTrygve Laugstøl <trygvis@inamo.no>2016-07-26 21:17:20 +0200
committerTrygve Laugstøl <trygvis@inamo.no>2016-07-26 21:17:20 +0200
commit4d8b6e0ceeb9c8df06decf33b83781adc00cbead (patch)
tree8adb7fffd5f609a7549f2cf21eca7803d8c1a326 /CMakeLists.txt
parentea58b3887a7deba05e3fc85eb536038a547f8871 (diff)
downloadelfinfo-master.tar.gz
elfinfo-master.tar.bz2
elfinfo-master.tar.xz
elfinfo-master.zip
cleaning.HEADmaster
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 7 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ddbe243..9c6b7f2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,13 +7,14 @@ find_package(Antlr4)
antlr4_add_target(TARGET GnuLd STATIC LEXER GnuLdLexer.g4 PARSER GnuLdParser.g4)
-add_executable(elfinfo elfinfo.cpp Ld.cpp includes/trygvis/elfinfo/Ld.h)
+add_executable(elfinfo elfinfo.cpp Ld.cpp include/trygvis/elfinfo/Ld.h include-priv/trygvis/antlr.h)
target_compile_options(elfinfo PUBLIC "--std=c++14")
target_link_libraries(elfinfo elf GnuLd Antlr4::antlr4_shared)
-target_include_directories(elfinfo PUBLIC includes/trygvis/elfinfo)
+target_include_directories(elfinfo
+ PUBLIC include
+ PRIVATE include-priv)
INSTALL(TARGETS elfinfo
- RUNTIME DESTINATION bin
- LIBRARY DESTINATION lib
- ARCHIVE DESTINATION lib
-)
+ RUNTIME DESTINATION bin
+ LIBRARY DESTINATION lib
+ ARCHIVE DESTINATION lib)