aboutsummaryrefslogtreecommitdiff
path: root/core/CMakeLists.txt
diff options
context:
space:
mode:
authorTrygve Laugstøl <trygvis@inamo.no>2016-08-01 08:20:23 +0200
committerTrygve Laugstøl <trygvis@inamo.no>2016-08-01 08:20:23 +0200
commitbfeeac6e4889d1e9a1083b3c7efc59652981b168 (patch)
treea937d844a59da7c509685dcd1ddd9933772e526f /core/CMakeLists.txt
parentc307e9f234e544386fa3ae53083c7510668e1716 (diff)
downloadkicad-utils-bfeeac6e4889d1e9a1083b3c7efc59652981b168.tar.gz
kicad-utils-bfeeac6e4889d1e9a1083b3c7efc59652981b168.tar.bz2
kicad-utils-bfeeac6e4889d1e9a1083b3c7efc59652981b168.tar.xz
kicad-utils-bfeeac6e4889d1e9a1083b3c7efc59652981b168.zip
o Moving the generation logic to Python, embedding a Python interpreter with the help of pybind11.
o Adding install configuration to CMake to make it easier to reuse the project later on. o Splitting out the examples into its own project to make it easier to test the whole installation setup and python/template loading. o Trying to reorganize the code a bit, not very much better yet.
Diffstat (limited to 'core/CMakeLists.txt')
-rw-r--r--core/CMakeLists.txt22
1 files changed, 22 insertions, 0 deletions
diff --git a/core/CMakeLists.txt b/core/CMakeLists.txt
new file mode 100644
index 0000000..cbf8e78
--- /dev/null
+++ b/core/CMakeLists.txt
@@ -0,0 +1,22 @@
+find_package(Antlr4)
+
+set(CMAKE_POSITION_INDEPENDENT_CODE ON)
+
+antlr4_add_target(
+ TARGET KicadNet
+ LEXER KicadNetLexer.g4
+ PARSER KicadNetParser.g4
+ STATIC)
+
+add_library(kicad-utils-core
+ kicad.cpp)
+target_sources(kicad-utils-core PRIVATE $<TARGET_OBJECTS:KicadNet>)
+
+get_target_property(KicadNet_includes KicadNet INCLUDE_DIRECTORIES)
+
+target_include_directories(kicad-utils-core
+ PUBLIC include
+ PRIVATE include-priv ${KicadNet_includes})
+
+target_link_libraries(kicad-utils-core
+ Antlr4::antlr4_shared)