aboutsummaryrefslogtreecommitdiff
path: root/examples/arduino-led/CMakeLists.txt
diff options
context:
space:
mode:
authorTrygve Laugstøl <trygvis@inamo.no>2016-07-26 00:22:55 +0200
committerTrygve Laugstøl <trygvis@inamo.no>2016-07-26 00:22:55 +0200
commit128e53d220d97225803d61d86f8e43439563181d (patch)
treee0d5da8d666c54d1d17e64ee6f52af424129f90d /examples/arduino-led/CMakeLists.txt
downloadkicad-utils-128e53d220d97225803d61d86f8e43439563181d.tar.gz
kicad-utils-128e53d220d97225803d61d86f8e43439563181d.tar.bz2
kicad-utils-128e53d220d97225803d61d86f8e43439563181d.tar.xz
kicad-utils-128e53d220d97225803d61d86f8e43439563181d.zip
WIP: kicad_gen is a util to generate schematic.h files from KiCAD netlist files.
Current code contains a lexer and parser for KiCAD's netlist files and code to build a tree of the netlist which can be used for generation. Contains CMake code for integrating the generation into CMake too.
Diffstat (limited to 'examples/arduino-led/CMakeLists.txt')
-rw-r--r--examples/arduino-led/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/examples/arduino-led/CMakeLists.txt b/examples/arduino-led/CMakeLists.txt
new file mode 100644
index 0000000..7bd82af
--- /dev/null
+++ b/examples/arduino-led/CMakeLists.txt
@@ -0,0 +1,14 @@
+kicad_gen(
+ TARGET schematic.h
+ NET schematic/arduino-led.net
+ REF U1
+ IN_SOURCE)
+
+if (FALSE)
+ # If you have Arduino support for CMake something like this would work:
+
+ #add_executable(arduino-led arduino-led.ino schematic.h)
+ #target_include_directories(arduino-led PUBLIC ${CMAKE_CURRENT_BINARY_DIR}/kicad-include)
+else ()
+ add_custom_target(arduino-led ALL DEPENDS ${CMAKE_CURRENT_SOURCE_DIR}/schematic.h)
+endif ()