aboutsummaryrefslogtreecommitdiff
path: root/python/CMakeLists.txt
diff options
context:
space:
mode:
authorTrygve Laugstøl <trygvis@inamo.no>2016-08-01 08:20:23 +0200
committerTrygve Laugstøl <trygvis@inamo.no>2016-08-01 08:20:23 +0200
commitbfeeac6e4889d1e9a1083b3c7efc59652981b168 (patch)
treea937d844a59da7c509685dcd1ddd9933772e526f /python/CMakeLists.txt
parentc307e9f234e544386fa3ae53083c7510668e1716 (diff)
downloadkicad-utils-bfeeac6e4889d1e9a1083b3c7efc59652981b168.tar.gz
kicad-utils-bfeeac6e4889d1e9a1083b3c7efc59652981b168.tar.bz2
kicad-utils-bfeeac6e4889d1e9a1083b3c7efc59652981b168.tar.xz
kicad-utils-bfeeac6e4889d1e9a1083b3c7efc59652981b168.zip
o Moving the generation logic to Python, embedding a Python interpreter with the help of pybind11.
o Adding install configuration to CMake to make it easier to reuse the project later on. o Splitting out the examples into its own project to make it easier to test the whole installation setup and python/template loading. o Trying to reorganize the code a bit, not very much better yet.
Diffstat (limited to 'python/CMakeLists.txt')
-rw-r--r--python/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/python/CMakeLists.txt b/python/CMakeLists.txt
new file mode 100644
index 0000000..2b612b9
--- /dev/null
+++ b/python/CMakeLists.txt
@@ -0,0 +1,13 @@
+add_subdirectory(pybind11)
+
+pybind11_add_module(kicad_utils_py kicad_utils_py.cpp
+ include/trygvis/kicad/python.h
+ GenerateHeaderPy.cpp include/trygvis/kicad/GenerateHeaderPy.h)
+pybind11_enable_warnings(kicad_utils_py)
+
+target_include_directories(kicad_utils_py PRIVATE include)
+target_link_libraries(kicad_utils_py PRIVATE kicad-utils-core)
+
+install(TARGETS kicad_utils_py
+ EXPORT kicad_utils_export
+ LIBRARY DESTINATION lib)