aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTrygve Laugstøl <trygvis@inamo.no>2017-04-07 19:03:05 +0200
committerTrygve Laugstøl <trygvis@inamo.no>2017-04-07 19:03:05 +0200
commit36e59a1991f075e36e117a08321d5e4c4dc00eac (patch)
tree2c89d0b9ad67eb6ebdcd5ed4b1789ebc61ce6723 /CMakeLists.txt
parent84939234eb66fe7957eaf39956f18224e3108c25 (diff)
downloadwifi-triangulator-36e59a1991f075e36e117a08321d5e4c4dc00eac.tar.gz
wifi-triangulator-36e59a1991f075e36e117a08321d5e4c4dc00eac.tar.bz2
wifi-triangulator-36e59a1991f075e36e117a08321d5e4c4dc00eac.tar.xz
wifi-triangulator-36e59a1991f075e36e117a08321d5e4c4dc00eac.zip
o Splitting capture into just two, capture and send to stdout and transmit from stdin.
o Adding formatter that formats the incoming message.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 11 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6fa065d..141beda 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -22,7 +22,7 @@ include_directories(${Protobuf_INCLUDE_DIRS} ${Protobuf_INCLUDE_DIR})
protobuf_generate_cpp(PROTO_SRC PROTO_HEADER wifi-triangulator.proto)
add_library(wifi-triangulator
- core.cpp misc.cpp
+ src/core.cpp src/misc.cpp
${PROTO_SRC}
${PROTO_HEADER}
include/wifi-triangulator/core.h
@@ -34,9 +34,17 @@ target_include_directories(wifi-triangulator PUBLIC include ${CMAKE_CURRENT_BINA
target_link_libraries(wifi-triangulator PUBLIC pcap ${Protobuf_LIBRARIES})
# capture
-add_executable(capture capture.cpp)
+add_executable(capture src/capture.cpp)
target_link_libraries(capture PUBLIC wifi-triangulator)
+# transmitter
+add_executable(transmitter src/transmitter.cpp)
+target_link_libraries(transmitter PUBLIC wifi-triangulator)
+
# receiver
-add_executable(receiver receiver.cpp)
+add_executable(receiver src/receiver.cpp)
target_link_libraries(receiver PUBLIC wifi-triangulator)
+
+# formatter
+add_executable(formatter src/formatter.cpp)
+target_link_libraries(formatter PUBLIC wifi-triangulator)