summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTrygve Laugstøl <trygvis@inamo.no>2017-06-06 09:11:22 +0200
committerTrygve Laugstøl <trygvis@inamo.no>2017-06-06 09:11:22 +0200
commit1729acd9b72369af45ee5ed45a8d29642f3df367 (patch)
tree652f3f679b27287c9be6d3ea0676188f87fa5f33 /CMakeLists.txt
parent4ee01dab6105e346b731a13321a3e6a5d111d3e4 (diff)
downloadradio-controller-1729acd9b72369af45ee5ed45a8d29642f3df367.tar.gz
radio-controller-1729acd9b72369af45ee5ed45a8d29642f3df367.tar.bz2
radio-controller-1729acd9b72369af45ee5ed45a8d29642f3df367.tar.xz
radio-controller-1729acd9b72369af45ee5ed45a8d29642f3df367.zip
wip
o Dropping Samsung-specific code, will be replaces by a small script. o Starting on some unit test code.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 11 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 52c9c42..7d88671 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -13,7 +13,6 @@ add_executable(firmware src/radio-controller.cpp
include/decoder.h
include/misc.h
include/radio-controller.h
- include/samsung_decoder.h
include)
target_compile_definitions(firmware PUBLIC MCUCMAKE_USING_STM32CUBE=1)
target_include_directories(firmware PUBLIC include)
@@ -53,3 +52,14 @@ mcu_include_directories_from_sources(
list(FILTER BSP_INCLUDES INCLUDE REGEX Inc)
target_include_directories(firmware PUBLIC ${BSP_INCLUDES})
target_sources(firmware PUBLIC ${BSP_SOURCES} ${BSP_HEADERS})
+
+ExternalProject_Add(build-tests
+ SOURCE_DIR ${CMAKE_CURRENT_LIST_DIR}/test
+# EXCLUDE_FROM_ALL TRUE
+ CMAKE_ARGS "-DCMAKE_INSTALL_PREFIX=${CMAKE_BINARY_DIR}"
+ INSTALL_COMMAND "")
+
+add_custom_target(run-tests ALL
+ COMMAND ${CMAKE_BINARY_DIR}/tests-prefix/src/tests-build/tests
+ DEPENDS build-tests
+ )