summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTrygve Laugstøl <trygvis@inamo.no>2017-05-26 09:33:28 +0200
committerTrygve Laugstøl <trygvis@inamo.no>2017-05-26 09:33:28 +0200
commit46b7f97720293e098fa26eb5269b481c45819deb (patch)
treea99550aa1b045fac84e682f1034d6fe2952fb3f8 /CMakeLists.txt
parent8a0f9a5bdc69ef8ce457a6c5db6a4c144f822ac3 (diff)
downloadradio-controller-46b7f97720293e098fa26eb5269b481c45819deb.tar.gz
radio-controller-46b7f97720293e098fa26eb5269b481c45819deb.tar.bz2
radio-controller-46b7f97720293e098fa26eb5269b481c45819deb.tar.xz
radio-controller-46b7f97720293e098fa26eb5269b481c45819deb.zip
o Updating to latest mcucpp.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bf1aecd..4fc7403 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,6 +1,6 @@
cmake_minimum_required(VERSION 3.6)
set(MCU_CHIP stm32f103C6)
-set(MCU_USE_STM32CUBEMX TRUE)
+set(MCU_USE_STM32CUBE TRUE)
set(MCU_LTO_MODE OFF)
include(thirdparty/mcu.cmake/mcu.cmake)
project(radio-controller C CXX ASM)
@@ -10,7 +10,7 @@ set(CMAKE_CXX_STANDARD 14)
include(thirdparty/mcucpp/cmake/mcucpp.cmake)
add_executable(firmware src/radio-controller.cpp include/radio-controller.h)
-target_compile_definitions(firmware PUBLIC MCUCMAKE_USING_STM32CUBEMX=1)
+target_compile_definitions(firmware PUBLIC MCUCMAKE_USING_STM32CUBE=1)
target_include_directories(firmware PUBLIC include)
target_link_libraries(firmware PUBLIC gcc)
mcu_add_executable(TARGET firmware)
@@ -34,7 +34,7 @@ target_sources(firmware PUBLIC
mcucpp_process(TARGET firmware)
-# stm32cubemx sources
+# stm32cube sources
mcu_include_directories_from_sources(
SOURCE_DIR stm32cubemx
EXCLUDE Templates