aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorTrygve Laugstøl <trygvis@inamo.no>2017-09-10 12:32:49 +0200
committerTrygve Laugstøl <trygvis@inamo.no>2017-09-10 12:32:49 +0200
commit090a2703703877bd150aae637031c5d7dcba2df4 (patch)
tree3d498820503e1ab3c7186c2839a661a76083550b /setup.py
parentc96bc5755a68d8e317d96be31b330cc0b626c194 (diff)
downloadee-python-090a2703703877bd150aae637031c5d7dcba2df4.tar.gz
ee-python-090a2703703877bd150aae637031c5d7dcba2df4.tar.bz2
ee-python-090a2703703877bd150aae637031c5d7dcba2df4.tar.xz
ee-python-090a2703703877bd150aae637031c5d7dcba2df4.zip
setup.py: Adding install_requires.
digikey: Updating tests. Making sure the directory exist before writing facts. Stop recursing into new searches when a search returns multiple hits. Let the frontends do that.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py37
1 files changed, 25 insertions, 12 deletions
diff --git a/setup.py b/setup.py
index 1580612..0470b81 100644
--- a/setup.py
+++ b/setup.py
@@ -1,16 +1,29 @@
from distutils.core import setup
-from glob import glob
-from os.path import basename
-from os.path import dirname
-from os.path import join
-from os.path import splitext
+
from setuptools import find_packages
setup(name='ee',
- version='1.0',
- packages=find_packages('src'),
- package_dir={'': 'src'},
- entry_points = {
- 'console_scripts': ['ee=ee.__main__:main'],
- },
- )
+ version='1.0',
+ packages=find_packages('src'),
+ package_dir={'': 'src'},
+ entry_points={
+ 'console_scripts': ['ee=ee.__main__:main'],
+ },
+ install_requires=[
+ 'ansicolors',
+ 'cachecontrol',
+ 'lockfile',
+ 'lxml',
+ 'matplotlib',
+ 'mpmath',
+ 'mypy',
+ 'numpy',
+ 'pandas',
+ 'parsec',
+ 'Pillow',
+ 'pytest',
+ 'pyyaml',
+ 'requests',
+ 'sympy',
+ ],
+ )