aboutsummaryrefslogtreecommitdiff
path: root/thirdparty/nRF5_SDK_15.0.0_a53641a/external/mbedtls/include/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'thirdparty/nRF5_SDK_15.0.0_a53641a/external/mbedtls/include/CMakeLists.txt')
-rw-r--r--thirdparty/nRF5_SDK_15.0.0_a53641a/external/mbedtls/include/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/thirdparty/nRF5_SDK_15.0.0_a53641a/external/mbedtls/include/CMakeLists.txt b/thirdparty/nRF5_SDK_15.0.0_a53641a/external/mbedtls/include/CMakeLists.txt
new file mode 100644
index 0000000..985a353
--- /dev/null
+++ b/thirdparty/nRF5_SDK_15.0.0_a53641a/external/mbedtls/include/CMakeLists.txt
@@ -0,0 +1,11 @@
+option(INSTALL_MBEDTLS_HEADERS "Install mbed TLS headers." ON)
+
+if(INSTALL_MBEDTLS_HEADERS)
+
+ file(GLOB headers "mbedtls/*.h")
+
+ install(FILES ${headers}
+ DESTINATION include/mbedtls
+ PERMISSIONS OWNER_READ OWNER_WRITE GROUP_READ WORLD_READ)
+
+endif(INSTALL_MBEDTLS_HEADERS)