summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authoroharboe <oharboe@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2008-03-11 21:32:03 +0000
committeroharboe <oharboe@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2008-03-11 21:32:03 +0000
commit0313c595555ae1c391766d1594735042ccd20443 (patch)
treec540c8c4ab3fdd31417f34197206bbb0787b92de /configure.in
parentb9162dcc8e68413966c8493556e471fbdcb88a1f (diff)
downloadopenocd+libswd-0313c595555ae1c391766d1594735042ccd20443.tar.gz
openocd+libswd-0313c595555ae1c391766d1594735042ccd20443.tar.bz2
openocd+libswd-0313c595555ae1c391766d1594735042ccd20443.tar.xz
openocd+libswd-0313c595555ae1c391766d1594735042ccd20443.zip
reduce compare noise. If someone should be crazy enough to try to run OpenOCD under eCos, then they'v got some hooks to point them in the general direction.
git-svn-id: svn://svn.berlios.de/openocd/trunk@499 b42882b7-edfa-0310-969c-e2dbd0fdcd60
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 00bdbcdc..92107fa7 100644
--- a/configure.in
+++ b/configure.in
@@ -55,6 +55,10 @@ case "${host_cpu}" in
AS_HELP_STRING([--enable-ep93xx], [Enable building support for EP93xx based SBCs]),
[build_ep93xx=$enableval], [build_ep93xx=no])
+AC_ARG_ENABLE(ecosboard,
+ AS_HELP_STRING([--enable-ecosboard], [Enable building support for eCosBoard based JTAG debugger]),
+ [build_ecosboard=$enableval], [build_ecosboard=no])
+
AC_ARG_ENABLE(at91rm9200,
AS_HELP_STRING([--enable-at91rm9200], [Enable building support for AT91RM9200 based SBCs]),
[build_at91rm9200=$enableval], [build_at91rm9200=no])
@@ -142,6 +146,13 @@ else
AC_DEFINE(BUILD_EP93XX, 0, [0 if you don't want ep93xx.])
fi
+if test $build_ecosboard = yes; then
+ build_bitbang=yes
+ AC_DEFINE(BUILD_ECOSBOARD, 1, [1 if you want eCosBoard.])
+else
+ AC_DEFINE(BUILD_ECOSBOARD, 0, [0 if you don't want eCosBoard.])
+fi
+
if test $build_at91rm9200 = yes; then
build_bitbang=yes
AC_DEFINE(BUILD_AT91RM9200, 1, [1 if you want at91rm9200.])
@@ -229,6 +240,7 @@ AM_INIT_AUTOMAKE(openocd, 1.0)
AM_CONDITIONAL(PARPORT, test $build_parport = yes)
AM_CONDITIONAL(GIVEIO, test $parport_use_giveio = yes)
AM_CONDITIONAL(EP93XX, test $build_ep93xx = yes)
+AM_CONDITIONAL(ECOSBOARD, test $build_ecosboard = yes)
AM_CONDITIONAL(AT91RM9200, test $build_at91rm9200 = yes)
AM_CONDITIONAL(BITBANG, test $build_bitbang = yes)
AM_CONDITIONAL(FT2232_LIBFTDI, test $build_ft2232_libftdi = yes)