summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorØyvind Harboe <oyvind.harboe@zylin.com>2010-09-07 20:19:05 +0200
committerØyvind Harboe <oyvind.harboe@zylin.com>2010-09-20 13:08:16 +0200
commit32ab98c9e9672d0f1d8758c7dfb478b0316c13af (patch)
treef1cc00ce9a20b8783e90a44c5bd402dae5a0c590 /configure.in
parent1dbb7ba47259f99905b590d6118771113edfc142 (diff)
downloadopenocd+libswd-32ab98c9e9672d0f1d8758c7dfb478b0316c13af.tar.gz
openocd+libswd-32ab98c9e9672d0f1d8758c7dfb478b0316c13af.tar.bz2
openocd+libswd-32ab98c9e9672d0f1d8758c7dfb478b0316c13af.tar.xz
openocd+libswd-32ab98c9e9672d0f1d8758c7dfb478b0316c13af.zip
zy1000: split out configure option for eCos and JTAG master
Signed-off-by: Øyvind Harboe <oyvind.harboe@zylin.com>
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 7f31e1de..a15b80a6 100644
--- a/configure.in
+++ b/configure.in
@@ -408,6 +408,10 @@ AC_ARG_ENABLE(ecosboard,
AS_HELP_STRING([--enable-ecosboard], [Enable building support for eCos based JTAG debugger]),
[build_ecosboard=$enableval], [build_ecosboard=no])
+AC_ARG_ENABLE(zy1000_master,
+ AS_HELP_STRING([--enable-zy1000-master], [Use ZY1000 JTAG master registers]),
+ [build_zy1000_master=$enableval], [build_zy1000_master=no])
+
AC_ARG_ENABLE(zy1000,
AS_HELP_STRING([--enable-zy1000], [Enable ZY1000 interface]),
[build_zy1000=$enableval], [build_zy1000=no])
@@ -626,6 +630,12 @@ else
AC_DEFINE(BUILD_ZY1000, 0, [0 if you don't want ZY1000.])
fi
+if test $build_zy1000_master = yes; then
+ AC_DEFINE(BUILD_ZY1000_MASTER, 1, [1 if you want ZY1000 JTAG master registers.])
+else
+ AC_DEFINE(BUILD_ZY1000_MASTER, 0, [0 if you don't want ZY1000 JTAG master registers.])
+fi
+
if test $build_at91rm9200 = yes; then
build_bitbang=yes
AC_DEFINE(BUILD_AT91RM9200, 1, [1 if you want at91rm9200.])
@@ -1027,6 +1037,7 @@ AM_CONDITIONAL(GIVEIO, test x$parport_use_giveio = xyes)
AM_CONDITIONAL(EP93XX, test $build_ep93xx = yes)
AM_CONDITIONAL(ECOSBOARD, test $build_ecosboard = yes)
AM_CONDITIONAL(ZY1000, test $build_zy1000 = yes)
+AM_CONDITIONAL(ZY1000_MASTER, test $build_zy1000_master = yes)
AM_CONDITIONAL(IOUTIL, test $build_ioutil = yes)
AM_CONDITIONAL(HTTPD, test $build_httpd = yes)
AM_CONDITIONAL(AT91RM9200, test $build_at91rm9200 = yes)