summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorntfreak <ntfreak@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2008-05-14 14:13:38 +0000
committerntfreak <ntfreak@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2008-05-14 14:13:38 +0000
commit548bb19aa28ca2eec4b8f1c06cbb4b0ace162db3 (patch)
tree3652a17e6c525942d3a2becfa05dbda1d9972437 /configure.in
parentf1e72cf029f28a337679ca787003c54d5c1e2bde (diff)
downloadopenocd+libswd-548bb19aa28ca2eec4b8f1c06cbb4b0ace162db3.tar.gz
openocd+libswd-548bb19aa28ca2eec4b8f1c06cbb4b0ace162db3.tar.bz2
openocd+libswd-548bb19aa28ca2eec4b8f1c06cbb4b0ace162db3.tar.xz
openocd+libswd-548bb19aa28ca2eec4b8f1c06cbb4b0ace162db3.zip
- added jlink support, based on Jürgen Stuber patch
git-svn-id: svn://svn.berlios.de/openocd/trunk@658 b42882b7-edfa-0310-969c-e2dbd0fdcd60
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index ae35f555..eebbc376 100644
--- a/configure.in
+++ b/configure.in
@@ -99,6 +99,10 @@ AC_ARG_ENABLE(oocd_trace,
AS_HELP_STRING([--enable-oocd_trace], [Enable building support for the OpenOCD+trace ETM capture device]),
[build_oocd_trace=$enableval], [build_oocd_trace=no])
+AC_ARG_ENABLE(jlink,
+ AS_HELP_STRING([--enable-jlink], [Enable building support for the Segger J-Link JTAG Programmer]),
+ [build_jlink=$enableval], [build_jlink=no])
+
AC_ARG_WITH(ftd2xx,
[AS_HELP_STRING(--with-ftd2xx,
[Where libftd2xx can be found <default=search>])],
@@ -251,6 +255,12 @@ else
AC_DEFINE(BUILD_OOCD_TRACE, 0, [0 if you don't want the OpenOCD+trace ETM capture driver.])
fi
+if test $build_jlink = yes; then
+ AC_DEFINE(BUILD_JLINK, 1, [1 if you want the J-Link JTAG driver.])
+else
+ AC_DEFINE(BUILD_JLINK, 0, [0 if you don't want the J-Link JTAG driver.])
+fi
+
AM_CONFIG_HEADER(config.h)
AM_INIT_AUTOMAKE(openocd, 1.0)
@@ -269,6 +279,7 @@ AM_CONDITIONAL(PRESTO_LIBFTDI, test $build_presto_libftdi = yes)
AM_CONDITIONAL(PRESTO_FTD2XX, test $build_presto_ftd2xx = yes)
AM_CONDITIONAL(USBPROG, test $build_usbprog = yes)
AM_CONDITIONAL(OOCD_TRACE, test $build_oocd_trace = yes)
+AM_CONDITIONAL(JLINK, test $build_jlink = yes)
AM_CONDITIONAL(IS_CYGWIN, test $is_cygwin = yes)
AM_CONDITIONAL(IS_MINGW, test $is_mingw = yes)
AM_CONDITIONAL(IS_WIN32, test $is_win32 = yes)