summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authoroharboe <oharboe@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2009-04-21 11:37:15 +0000
committeroharboe <oharboe@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2009-04-21 11:37:15 +0000
commit5b4679618a0f1b14f6ee47fc30cf27f77375f2d4 (patch)
tree0b4c00995047be396a92bf8317ee3b1d8d2f4778 /configure.in
parent837555ab24ab32af163b5dd295dcdbc3c238ad6f (diff)
downloadopenocd+libswd-5b4679618a0f1b14f6ee47fc30cf27f77375f2d4.tar.gz
openocd+libswd-5b4679618a0f1b14f6ee47fc30cf27f77375f2d4.tar.bz2
openocd+libswd-5b4679618a0f1b14f6ee47fc30cf27f77375f2d4.tar.xz
openocd+libswd-5b4679618a0f1b14f6ee47fc30cf27f77375f2d4.zip
Zach Welch <zw@superlucidity.net> add --enable-verbose* options
git-svn-id: svn://svn.berlios.de/openocd/trunk@1495 b42882b7-edfa-0310-969c-e2dbd0fdcd60
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in45
1 files changed, 45 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 458bb0c6..67a4b98f 100644
--- a/configure.in
+++ b/configure.in
@@ -189,6 +189,51 @@ AC_ARG_ENABLE(werror,
AS_HELP_STRING([--disable-werror], [Do not treat warnings as errors]),
[gcc_werror=$enableval], [gcc_werror=$gcc_warnings])
+# set default verbose options, overridden by following options
+debug_jtag_io=no
+debug_usb_io=no
+debug_usb_comms=no
+
+AC_ARG_ENABLE(verbose,
+ AS_HELP_STRING([--enable-verbose],
+ [Enable verbose JTAG I/O messages (for debugging).]),
+ [
+ debug_jtag_io=$enableval
+ debug_usb_io=$enableval
+ debug_usb_comms=$enableval
+ ], [])
+
+AC_ARG_ENABLE(verbose_jtag_io,
+ AS_HELP_STRING([--enable-verbose-jtag-io],
+ [Enable verbose JTAG I/O messages (for debugging).]),
+ [debug_jtag_io=$enableval], [])
+AC_ARG_ENABLE(verbose_usb_io,
+ AS_HELP_STRING([--enable-verbose-usb-io],
+ [Enable verbose USB I/O messages (for debugging)]),
+ [debug_usb_io=$enableval], [])
+AC_ARG_ENABLE(verbose_usb_comms,
+ AS_HELP_STRING([--enable-verbose-usb-comms],
+ [Enable verbose USB communication messages (for debugging)]),
+ [debug_usb_comms=$enableval], [])
+
+AC_MSG_CHECKING([whether to enable verbose JTAB I/O messages]);
+AC_MSG_RESULT($debug_jtag_io)
+if test $debug_jtag_io = yes; then
+ AC_DEFINE([_DEBUG_JTAG_IO_],[1], [Print verbose JTAG I/O messages])
+fi
+
+AC_MSG_CHECKING([whether to enable verbose USB I/O messages]);
+AC_MSG_RESULT($debug_usb_io)
+if test $debug_usb_io = yes; then
+ AC_DEFINE([_DEBUG_USB_IO_],[1], [Print verbose USB I/O messages])
+fi
+
+AC_MSG_CHECKING([whether to enable verbose USB communication messages]);
+AC_MSG_RESULT($debug_usb_comms)
+if test $debug_usb_comms = yes; then
+ AC_DEFINE([_DEBUG_USB_COMMS_],[1], [Print verbose USB communication messages])
+fi
+
AC_ARG_ENABLE(parport,
AS_HELP_STRING([--enable-parport], [Enable building the pc parallel port driver]),