summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authoroharboe <oharboe@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2009-04-27 05:30:15 +0000
committeroharboe <oharboe@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2009-04-27 05:30:15 +0000
commit60fdeb057a53597bbd1b05b9fbc7c2d05fe8d143 (patch)
tree96fd2f78b971a9ad64db96f8728db4940a118566 /configure.in
parent70d80bba5aa9f7ba5d24625265ef549770f592c4 (diff)
downloadopenocd+libswd-60fdeb057a53597bbd1b05b9fbc7c2d05fe8d143.tar.gz
openocd+libswd-60fdeb057a53597bbd1b05b9fbc7c2d05fe8d143.tar.bz2
openocd+libswd-60fdeb057a53597bbd1b05b9fbc7c2d05fe8d143.tar.xz
openocd+libswd-60fdeb057a53597bbd1b05b9fbc7c2d05fe8d143.zip
Zach Welch <zw@superlucidity.net> add -Wcast-align and -Wbad-function-cast
git-svn-id: svn://svn.berlios.de/openocd/trunk@1533 b42882b7-edfa-0310-969c-e2dbd0fdcd60
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 632aaf8a..88590137 100644
--- a/configure.in
+++ b/configure.in
@@ -776,6 +776,8 @@ AC_PROG_RANLIB
GCC_WARNINGS="-Wall -Wstrict-prototypes -Wformat-security"
if test "${gcc_wextra}" = yes; then
GCC_WARNINGS="${GCC_WARNINGS} -Wextra -Wno-unused-parameter"
+ GCC_WARNINGS="${GCC_WARNINGS} -Wbad-function-cast"
+ GCC_WARNINGS="${GCC_WARNINGS} -Wcast-align"
fi
if test "${gcc_werror}" = yes; then
GCC_WARNINGS="${GCC_WARNINGS} -Werror"