summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authordrath <drath@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2006-07-17 14:13:27 +0000
committerdrath <drath@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2006-07-17 14:13:27 +0000
commit82d2633b5f550115e9e7c7d0520babb6680aa38f (patch)
treefa9895a6117d4a238be1b76293edcc7de11a88c2 /configure.in
parent1960973baf8022b4525e3ac94aed8dace7f9b478 (diff)
downloadopenocd+libswd-82d2633b5f550115e9e7c7d0520babb6680aa38f.tar.gz
openocd+libswd-82d2633b5f550115e9e7c7d0520babb6680aa38f.tar.bz2
openocd+libswd-82d2633b5f550115e9e7c7d0520babb6680aa38f.tar.xz
openocd+libswd-82d2633b5f550115e9e7c7d0520babb6680aa38f.zip
- Added support for native MinGW builds (thanks to Spencer Oliver and Michael Fischer) - you still need to install GiveIO (not part of OpenOCD)
- Added state-move support to ftd2xx and bitbang JTAG drivers (required for XScale, possibly useful for other targets, too) - various fixes git-svn-id: svn://svn.berlios.de/openocd/trunk@78 b42882b7-edfa-0310-969c-e2dbd0fdcd60
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in52
1 files changed, 42 insertions, 10 deletions
diff --git a/configure.in b/configure.in
index 8de2b832..2cf08cf4 100644
--- a/configure.in
+++ b/configure.in
@@ -7,9 +7,14 @@ AC_CANONICAL_HOST
AC_C_BIGENDIAN
AC_CHECK_FUNCS(strndup)
+AC_CHECK_FUNCS(strnlen)
+AC_CHECK_FUNCS(gettimeofday)
+AC_CHECK_FUNCS(usleep)
build_bitbang=no
is_cygwin=no
+is_mingw=no
+is_win32=no
AC_ARG_ENABLE(parport,
AS_HELP_STRING([--enable-parport], [Enable building the pc parallel port driver]),
@@ -41,6 +46,34 @@ AC_ARG_WITH(ftd2xx,
[],
with_ftd2xx=search)
+case $host in
+ *-*-cygwin*)
+ is_cygwin=yes
+ is_win32=yes
+
+ AC_ARG_ENABLE(parport_giveio,
+ AS_HELP_STRING([--enable-parport_giveio], [Enable use of giveio for parport instead of ioperm]),
+ [parport_use_giveio=$enableval], [parport_use_giveio=no])
+
+ AC_DEFINE(IS_CYGWIN, 1, [1 if building for Cygwin.])
+ AC_DEFINE(IS_WIN32, 1, [1 if building for Win32.])
+ ;;
+ *-*-mingw*)
+ is_mingw=yes
+ is_win32=yes
+
+ parport_use_giveio=yes
+
+ AC_DEFINE(IS_MINGW, 1, [1 if building for MinGW.])
+ AC_DEFINE(IS_WIN32, 1, [1 if building for Win32.])
+ ;;
+ *)
+ parport_use_giveio=no
+ AC_DEFINE(IS_CYGWIN, 0, [0 if not building for Cygwin.])
+ AC_DEFINE(IS_WIN32, 0, [0 if not building for Win32.])
+ ;;
+esac
+
if test $build_parport = yes; then
build_bitbang=yes
AC_DEFINE(BUILD_PARPORT, 1, [1 if you want parport.])
@@ -61,6 +94,12 @@ else
AC_DEFINE(PARPORT_USE_PPDEV, 0, [0 if you don't want parport to use ppdev.])
fi
+if test $parport_use_giveio = yes; then
+ AC_DEFINE(PARPORT_USE_GIVEIO, 1, [1 if you want parport to use giveio.])
+else
+ AC_DEFINE(PARPORT_USE_GIVEIO, 0, [0 if you don't want parport to use giveio.])
+fi
+
if test $build_bitbang = yes; then
AC_DEFINE(BUILD_BITBANG, 1, [1 if you want a bitbang interface.])
else
@@ -85,26 +124,19 @@ else
AC_DEFINE(BUILD_AMTJTAGACCEL, 0, [0 if you don't want the Amontec JTAG-Accelerator driver.])
fi
-case $host in
- *-*-cygwin*)
- is_cygwin=yes
- AC_DEFINE(IS_CYGWIN, 1, [1 if building for Cygwin.])
- ;;
- *)
- AC_DEFINE(IS_CYGWIN, 0, [0 if not building for Cygwin.])
- ;;
-esac
-
AM_CONFIG_HEADER(config.h)
AM_INIT_AUTOMAKE(openocd, 0.1)
AM_CONDITIONAL(PARPORT, test $build_parport = yes)
+AM_CONDITIONAL(GIVEIO, test $parport_use_giveio = yes)
AM_CONDITIONAL(EP93XX, test $build_ep93xx = yes)
AM_CONDITIONAL(BITBANG, test $build_bitbang = yes)
AM_CONDITIONAL(FTDI2232, test $build_ftdi2232 = yes)
AM_CONDITIONAL(FTD2XX, test $build_ftd2xx = yes)
AM_CONDITIONAL(AMTJTAGACCEL, test $build_amtjtagaccel = yes)
AM_CONDITIONAL(IS_CYGWIN, test $is_cygwin = yes)
+AM_CONDITIONAL(IS_MINGW, test $is_mingw = yes)
+AM_CONDITIONAL(IS_WIN32, test $is_win32 = yes)
AM_CONDITIONAL(FTD2XXDIR, test $with_ftd2xx != search)
AC_LANG_C