summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authordrath <drath@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2008-03-17 21:39:18 +0000
committerdrath <drath@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2008-03-17 21:39:18 +0000
commit87939e553d542ee2ec2b82075798838b77468ead (patch)
tree4693b048d0e09e10defc542d70c0909eb5c501ae /configure.in
parent3b2a068ea997323eb37251b31be8034c57ff9def (diff)
downloadopenocd+libswd-87939e553d542ee2ec2b82075798838b77468ead.tar.gz
openocd+libswd-87939e553d542ee2ec2b82075798838b77468ead.tar.bz2
openocd+libswd-87939e553d542ee2ec2b82075798838b77468ead.tar.xz
openocd+libswd-87939e553d542ee2ec2b82075798838b77468ead.zip
- fix warnings during configure cause by ecosboard. default to no, if host cpu isn't arm.
- fix generic bitbang code to allow scans to end in Shift-[ID]R - several CFI fixes (thanks to Michael Schwingen): - buffer overflow when converting target code in cfi_intel_write_block - cfi_fix_code_endian needs the number of words, not bytes, as size argument. - Spansion flash write was completely broken on big-endian targets - I borrowed mechanisms from the intel driver, and moved some common code into the cfi_command_val helper function. There is still more common code that might be cleaned up. - the buffer size check in cfi_write was broken for spansion flashes, where cfi_write_words is not implemented. cfi_write_words is no only called if the flash does have a buffer size >1. - "flash info" printed CFI status information for non-CFI flashes, which is confusing. It now only prints those when a real CFI flash is detected. git-svn-id: svn://svn.berlios.de/openocd/trunk@517 b42882b7-edfa-0310-969c-e2dbd0fdcd60
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 4 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 92107fa7..f2351fa0 100644
--- a/configure.in
+++ b/configure.in
@@ -55,9 +55,9 @@ case "${host_cpu}" in
AS_HELP_STRING([--enable-ep93xx], [Enable building support for EP93xx based SBCs]),
[build_ep93xx=$enableval], [build_ep93xx=no])
-AC_ARG_ENABLE(ecosboard,
- AS_HELP_STRING([--enable-ecosboard], [Enable building support for eCosBoard based JTAG debugger]),
- [build_ecosboard=$enableval], [build_ecosboard=no])
+ AC_ARG_ENABLE(ecosboard,
+ AS_HELP_STRING([--enable-ecosboard], [Enable building support for eCosBoard based JTAG debugger]),
+ [build_ecosboard=$enableval], [build_ecosboard=no])
AC_ARG_ENABLE(at91rm9200,
AS_HELP_STRING([--enable-at91rm9200], [Enable building support for AT91RM9200 based SBCs]),
@@ -67,6 +67,7 @@ AC_ARG_ENABLE(ecosboard,
*)
build_ep93xx=no
build_at91rm9200=no
+ build_ecosboard=no
;;
esac