summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authoroharboe <oharboe@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2009-06-17 10:51:34 +0000
committeroharboe <oharboe@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2009-06-17 10:51:34 +0000
commit8d8937f1a68e1b050b92f91b1d264bf4bd3af489 (patch)
treeccf3355aa5ee018ebd4e89aa4fdfeb2d7d7d5ad0 /configure.in
parentd727e31af99cebff95c41fd1d2b319fddea9edd1 (diff)
downloadopenocd+libswd-8d8937f1a68e1b050b92f91b1d264bf4bd3af489.tar.gz
openocd+libswd-8d8937f1a68e1b050b92f91b1d264bf4bd3af489.tar.bz2
openocd+libswd-8d8937f1a68e1b050b92f91b1d264bf4bd3af489.tar.xz
openocd+libswd-8d8937f1a68e1b050b92f91b1d264bf4bd3af489.zip
dummy driver now works under eCos
git-svn-id: svn://svn.berlios.de/openocd/trunk@2268 b42882b7-edfa-0310-969c-e2dbd0fdcd60
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in17
1 files changed, 14 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index ef552f5c..9250dc58 100644
--- a/configure.in
+++ b/configure.in
@@ -329,9 +329,13 @@ AC_ARG_ENABLE(amtjtagaccel,
[build_amtjtagaccel=$enableval], [build_amtjtagaccel=no])
AC_ARG_ENABLE(ecosboard,
- AS_HELP_STRING([--enable-ecosboard], [Enable building support for eCosBoard based JTAG debugger]),
+ AS_HELP_STRING([--enable-ecosboard], [Enable building support for eCos based JTAG debugger]),
[build_ecosboard=$enableval], [build_ecosboard=no])
+AC_ARG_ENABLE(zy1000,
+ AS_HELP_STRING([--enable-zy1000], [Enable ZY1000 interface]),
+ [build_zy1000=$enableval], [build_zy1000=no])
+
AC_ARG_ENABLE(ioutil,
AS_HELP_STRING([--enable-ioutil], [Enable ioutil functions - useful for standalone OpenOCD implementations]),
[build_ioutil=$enableval], [build_ioutil=no])
@@ -400,7 +404,7 @@ AC_ARG_ENABLE(minidriver_dummy,
build_minidriver=no
AC_MSG_CHECKING([whether to enable ZY1000 minidriver])
-if test $build_ecosboard = yes; then
+if test $build_zy1000 = yes; then
if test $build_minidriver = yes; then
AC_MSG_ERROR([Multiple minidriver options have been enabled.])
fi
@@ -408,7 +412,7 @@ if test $build_ecosboard = yes; then
[Define to 1 if you have the <jtag_minidriver.h> header file.])
build_minidriver=yes
fi
-AC_MSG_RESULT($build_ecosboard)
+AC_MSG_RESULT($build_zy1000)
AC_MSG_CHECKING([whether to enable dummy minidriver])
@@ -527,6 +531,12 @@ else
AC_DEFINE(BUILD_ECOSBOARD, 0, [0 if you don't want eCosBoard.])
fi
+if test $build_zy1000 = yes; then
+ AC_DEFINE(BUILD_ZY1000, 1, [1 if you want ZY1000.])
+else
+ AC_DEFINE(BUILD_ZY1000, 0, [0 if you don't want ZY1000.])
+fi
+
if test $build_ioutil = yes; then
AC_DEFINE(BUILD_IOUTIL, 1, [1 if you want ioutils.])
else
@@ -898,6 +908,7 @@ AM_CONDITIONAL(DUMMY, test $build_dummy = yes)
AM_CONDITIONAL(GIVEIO, test x$parport_use_giveio = xyes)
AM_CONDITIONAL(EP93XX, test $build_ep93xx = yes)
AM_CONDITIONAL(ECOSBOARD, test $build_ecosboard = yes)
+AM_CONDITIONAL(ZY1000, test $build_zy1000 = yes)
AM_CONDITIONAL(IOUTIL, test $build_ioutil = yes)
AM_CONDITIONAL(HTTPD, test $build_httpd = yes)
AM_CONDITIONAL(AT91RM9200, test $build_at91rm9200 = yes)