summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorntfreak <ntfreak@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2009-07-06 15:19:10 +0000
committerntfreak <ntfreak@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2009-07-06 15:19:10 +0000
commitd41f2bfb14a6b9b31062a328f0e05a9664eaca53 (patch)
tree8ff1a6361303cdcec51d8652bfd32722f36acaea /configure.in
parent26b60a6ade45d048a9bfc70ff5d7ee58d4197f9d (diff)
downloadopenocd+libswd-d41f2bfb14a6b9b31062a328f0e05a9664eaca53.tar.gz
openocd+libswd-d41f2bfb14a6b9b31062a328f0e05a9664eaca53.tar.bz2
openocd+libswd-d41f2bfb14a6b9b31062a328f0e05a9664eaca53.tar.xz
openocd+libswd-d41f2bfb14a6b9b31062a328f0e05a9664eaca53.zip
- fix build when using a cross compiler - do not try and run any host tools
- add missing types.h when platform does not contain elf.h git-svn-id: svn://svn.berlios.de/openocd/trunk@2482 b42882b7-edfa-0310-969c-e2dbd0fdcd60
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 5ce3ff3c..1dea31ff 100644
--- a/configure.in
+++ b/configure.in
@@ -824,7 +824,9 @@ main( int argc, char **argv )
AC_MSG_RESULT([Success!])
], [
AC_MSG_ERROR([Cannot build & run test program using ftd2xx.lib])
- ] )
+ ], [
+ AC_MSG_RESULT([Skipping as we are cross-compiling])
+ ])
AC_MSG_CHECKING([whether to build ftd2xx highspeed device support])
AC_MSG_RESULT([$want_ftd2xx_highspeed])
@@ -891,7 +893,10 @@ main( int argc, char **argv )
AC_MSG_RESULT([Success])
], [
AC_MSG_ERROR([Cannot build & run test program using libftdi])
+ ], [
+ AC_MSG_RESULT([Skipping as we are cross-compiling])
])
+
# Restore the 'unexpanded ldflags'
LDFLAGS=$LDFLAGS_SAVE
CFLAGS=$CFLAGS_SAVE