summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authordrath <drath@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2006-08-11 17:49:41 +0000
committerdrath <drath@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2006-08-11 17:49:41 +0000
commitec0f06db114d1cc9d1d59acd8f4e3b32414d5b8e (patch)
tree23644c757a85534a5daa6ce21b44c766321fba5d /configure.in
parentca1e5ee1f4236e2e384397bf6211ce56a1f687f5 (diff)
downloadopenocd+libswd-ec0f06db114d1cc9d1d59acd8f4e3b32414d5b8e.tar.gz
openocd+libswd-ec0f06db114d1cc9d1d59acd8f4e3b32414d5b8e.tar.bz2
openocd+libswd-ec0f06db114d1cc9d1d59acd8f4e3b32414d5b8e.tar.xz
openocd+libswd-ec0f06db114d1cc9d1d59acd8f4e3b32414d5b8e.zip
- added support for FreeBSD ppi (parallel port access similar to /dev/parport on linux) (thanks to Darius for this patch)
- unified 'ftd2xx' and 'ftdi2232' into a single interface 'ft2232'. The library used to access the hardware is choosen during configure with --enable-ft2232_ftd2xx or --enable-ft2232-libftdi. git-svn-id: svn://svn.berlios.de/openocd/trunk@83 b42882b7-edfa-0310-969c-e2dbd0fdcd60
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in28
1 files changed, 14 insertions, 14 deletions
diff --git a/configure.in b/configure.in
index 3518b38d..e2e9adec 100644
--- a/configure.in
+++ b/configure.in
@@ -24,13 +24,13 @@ AC_ARG_ENABLE(parport_ppdev,
AS_HELP_STRING([--enable-parport_ppdev], [Enable use of ppdev (/dev/parportN) for parport]),
[parport_use_ppdev=$enableval], [parport_use_ppdev=no])
-AC_ARG_ENABLE(ftdi2232,
- AS_HELP_STRING([--enable-ftdi2232], [Enable building the libftdi ft2232c driver]),
- [build_ftdi2232=$enableval], [build_ftdi2232=no])
+AC_ARG_ENABLE(ft2232_libftdi,
+ AS_HELP_STRING([--enable-ft2232_libftdi], [Enable building support for FT2232 based devices using the libftdi driver]),
+ [build_ft2232_libftdi=$enableval], [build_ft2232_libftdi=no])
-AC_ARG_ENABLE(ftd2xx,
- AS_HELP_STRING([--enable-ftd2xx], [Enable building the ftd2xx ft2232c driver]),
- [build_ftd2xx=$enableval], [build_ftd2xx=no])
+AC_ARG_ENABLE(ft2232_ftd2xx,
+ AS_HELP_STRING([--enable-ft2232_ftd2xx], [Enable building support for FT2232 based devices using the FTD2XX driver]),
+ [build_ft2232_ftd2xx=$enableval], [build_ft2232_ftd2xx=no])
AC_ARG_ENABLE(amtjtagaccel,
AS_HELP_STRING([--enable-amtjtagaccel], [Enable building the Amontec JTAG-Accelerator driver]),
@@ -114,16 +114,16 @@ else
AC_DEFINE(BUILD_BITBANG, 0, [0 if you don't want a bitbang interface.])
fi
-if test $build_ftdi2232 = yes; then
- AC_DEFINE(BUILD_FTDI2232, 1, [1 if you want libftdi ft2232.])
+if test $build_ft2232_libftdi = yes; then
+ AC_DEFINE(BUILD_FT2232_LIBFTDI, 1, [1 if you want libftdi ft2232.])
else
- AC_DEFINE(BUILD_FTDI2232, 0, [0 if you don't want libftdi ft2232.])
+ AC_DEFINE(BUILD_FT2232_LIBFTDI, 0, [0 if you don't want libftdi ft2232.])
fi
-if test $build_ftd2xx = yes; then
- AC_DEFINE(BUILD_FTD2XX, 1, [1 if you want ftd2xx ft2232.])
+if test $build_ft2232_ftd2xx = yes; then
+ AC_DEFINE(BUILD_FT2232_FTD2XX, 1, [1 if you want ftd2xx ft2232.])
else
- AC_DEFINE(BUILD_FTD2XX, 0, [0 if you don't want ftd2xx ft2232.])
+ AC_DEFINE(BUILD_FT2232_FTD2XX, 0, [0 if you don't want ftd2xx ft2232.])
fi
if test $build_amtjtagaccel = yes; then
@@ -139,8 +139,8 @@ AM_CONDITIONAL(PARPORT, test $build_parport = yes)
AM_CONDITIONAL(GIVEIO, test $parport_use_giveio = yes)
AM_CONDITIONAL(EP93XX, test $build_ep93xx = yes)
AM_CONDITIONAL(BITBANG, test $build_bitbang = yes)
-AM_CONDITIONAL(FTDI2232, test $build_ftdi2232 = yes)
-AM_CONDITIONAL(FTD2XX, test $build_ftd2xx = yes)
+AM_CONDITIONAL(FT2232_LIBFTDI, test $build_ft2232_libftdi = yes)
+AM_CONDITIONAL(FT2232_FTD2XX, test $build_ft2232_ftd2xx = yes)
AM_CONDITIONAL(AMTJTAGACCEL, test $build_amtjtagaccel = yes)
AM_CONDITIONAL(IS_CYGWIN, test $is_cygwin = yes)
AM_CONDITIONAL(IS_MINGW, test $is_mingw = yes)