summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authoroharboe <oharboe@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2008-08-05 12:27:18 +0000
committeroharboe <oharboe@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2008-08-05 12:27:18 +0000
commitf370d70670bd5e30befe6fbfbc8d472e760f032b (patch)
tree881165e968757d8feae4e747b9407d98c328d373 /configure.in
parent20f505f695df9d9ba4c20780848336afec240a31 (diff)
downloadopenocd+libswd-f370d70670bd5e30befe6fbfbc8d472e760f032b.tar.gz
openocd+libswd-f370d70670bd5e30befe6fbfbc8d472e760f032b.tar.bz2
openocd+libswd-f370d70670bd5e30befe6fbfbc8d472e760f032b.tar.xz
openocd+libswd-f370d70670bd5e30befe6fbfbc8d472e760f032b.zip
Duane Ellis: fix warnings
git-svn-id: svn://svn.berlios.de/openocd/trunk@890 b42882b7-edfa-0310-969c-e2dbd0fdcd60
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 13 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 8f9b56f3..2c2f3cde 100644
--- a/configure.in
+++ b/configure.in
@@ -27,6 +27,12 @@ is_cygwin=no
is_mingw=no
is_win32=no
+
+AC_ARG_ENABLE(gccwarnings,
+ AS_HELP_STRING([--enable-gccwarnings], [Enable compiler warnings, default yes]),
+ [gcc_warnings=$enablevalue], [gcc_warnings=yes])
+
+
AC_ARG_ENABLE(parport,
AS_HELP_STRING([--enable-parport], [Enable building the pc parallel port driver]),
[build_parport=$enableval], [build_parport=no])
@@ -298,11 +304,17 @@ if test $cross_compiling = yes; then
CFLAGS_FOR_BUILD="-g -O2"
else
CC_FOR_BUILD=$CC
- CFLAGS_FOR_BUILD=$CFLAGS
+ CFLAGS_FOR_BUILD="$CFLAGS $GCC_WARNINGS"
fi
+
+if test $gcc_warnings = yes; then
+ CFLAGS_FOR_BUILD="$CFLAGS_FOR_BUILD -Wall -Wmissing-prototypes -Wstrict-prototypes"
+fi
+
AC_MSG_RESULT([$CC_FOR_BUILD])
AC_SUBST(CC_FOR_BUILD)
AC_SUBST(CFLAGS_FOR_BUILD)
+AC_MSG_NOTICE([CFLAGS_FOR_BUILD = $CFLAGS_FOR_BUILD])
AC_MSG_CHECKING([for suffix of executable build tools])
if test $cross_compiling = yes; then