summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authormifi <mifi@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2008-02-10 19:04:31 +0000
committermifi <mifi@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2008-02-10 19:04:31 +0000
commitfdf58f74e0cbc1a23ba74f9c1a7dae3260a36fae (patch)
treed5bf7268c52c7cba8f53f915fa48da326db7637c /configure.in
parentfb74f48b53a035a4bcbffba4057a5bf2e4e50d1f (diff)
downloadopenocd+libswd-fdf58f74e0cbc1a23ba74f9c1a7dae3260a36fae.tar.gz
openocd+libswd-fdf58f74e0cbc1a23ba74f9c1a7dae3260a36fae.tar.bz2
openocd+libswd-fdf58f74e0cbc1a23ba74f9c1a7dae3260a36fae.tar.xz
openocd+libswd-fdf58f74e0cbc1a23ba74f9c1a7dae3260a36fae.zip
- added starting point for development on a ngw100 eval board
git-svn-id: svn://svn.berlios.de/openocd/trunk@289 b42882b7-edfa-0310-969c-e2dbd0fdcd60
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index fd2584bb..d61e7fe5 100644
--- a/configure.in
+++ b/configure.in
@@ -65,6 +65,10 @@ case "${host_cpu}" in
;;
esac
+AC_ARG_ENABLE(ngw100,
+ AS_HELP_STRING([--enable-ngw100], [Enable building for NGW100 driver]),
+ [build_ngw100=$enableval], [build_ngw100=no])
+
AC_ARG_ENABLE(gw16012,
AS_HELP_STRING([--enable-gw16012], [Enable building support for the Gateworks GW16012 JTAG Programmer]),
[build_gw16012=$enableval], [build_gw16012=no])
@@ -148,6 +152,13 @@ else
AC_DEFINE(BUILD_AT91RM9200, 0, [0 if you don't want at91rm9200.])
fi
+if test $build_ngw100 = yes; then
+ build_bitbang=yes
+ AC_DEFINE(BUILD_NGW100, 1, [1 if you want ngw100.])
+else
+ AC_DEFINE(BUILD_NGW100, 0, [0 if you don't want ngw100.])
+fi
+
if test $parport_use_ppdev = yes; then
AC_DEFINE(PARPORT_USE_PPDEV, 1, [1 if you want parport to use ppdev.])
else
@@ -229,6 +240,7 @@ AM_CONDITIONAL(PARPORT, test $build_parport = yes)
AM_CONDITIONAL(GIVEIO, test $parport_use_giveio = yes)
AM_CONDITIONAL(EP93XX, test $build_ep93xx = yes)
AM_CONDITIONAL(AT91RM9200, test $build_at91rm9200 = yes)
+AM_CONDITIONAL(NGW100, test $build_ngw100 = yes)
AM_CONDITIONAL(BITBANG, test $build_bitbang = yes)
AM_CONDITIONAL(FT2232_LIBFTDI, test $build_ft2232_libftdi = yes)
AM_CONDITIONAL(FT2232_FTD2XX, test $build_ft2232_ftd2xx = yes)