summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authoroharboe <oharboe@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2008-03-11 21:32:03 +0000
committeroharboe <oharboe@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2008-03-11 21:32:03 +0000
commit0313c595555ae1c391766d1594735042ccd20443 (patch)
treec540c8c4ab3fdd31417f34197206bbb0787b92de /src/Makefile.am
parentb9162dcc8e68413966c8493556e471fbdcb88a1f (diff)
downloadopenocd+libswd-0313c595555ae1c391766d1594735042ccd20443.tar.gz
openocd+libswd-0313c595555ae1c391766d1594735042ccd20443.tar.bz2
openocd+libswd-0313c595555ae1c391766d1594735042ccd20443.tar.xz
openocd+libswd-0313c595555ae1c391766d1594735042ccd20443.zip
reduce compare noise. If someone should be crazy enough to try to run OpenOCD under eCos, then they'v got some hooks to point them in the general direction.
git-svn-id: svn://svn.berlios.de/openocd/trunk@499 b42882b7-edfa-0310-969c-e2dbd0fdcd60
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index aa315506..aa7b19f2 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,5 +1,13 @@
bin_PROGRAMS = openocd
-openocd_SOURCES = openocd.c
+
+if ECOSBOARD
+MAINFILE = ecosboard.c
+else
+MAINFILE = openocd.c
+endif
+
+
+openocd_SOURCES = $(MAINFILE)
# set the include path found by configure
INCLUDES = -I$(top_srcdir)/src/helper \