summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authordrath <drath@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2007-08-14 09:48:54 +0000
committerdrath <drath@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2007-08-14 09:48:54 +0000
commit29000b204d039bc1123027eba755329ab36a3dde (patch)
tree841d600e015592b5abd77b982dfb0d9cde51a399 /src/Makefile.am
parentabbd2b62ad445d4056567e2573416498a55da9af (diff)
downloadopenocd+libswd-29000b204d039bc1123027eba755329ab36a3dde.tar.gz
openocd+libswd-29000b204d039bc1123027eba755329ab36a3dde.tar.bz2
openocd+libswd-29000b204d039bc1123027eba755329ab36a3dde.tar.xz
openocd+libswd-29000b204d039bc1123027eba755329ab36a3dde.zip
- reworked presto.c to allow use of either FTD2XX or libftdi (libftdi not functional yet). Configure option changed from --enable-presto to
--enable-presto_ftd2xx and --enable-presto_libftdi - completed trace point support for use with ARM7/9 DCC - completed debug message output with support for HEX dumps (1, 2 or 4 byte quantities) - fixed bug in delete_debug_msg_receiver (thanks to Pavel Chromy) - fixed bug in image_add_section (thanks to Pavel Chromy) - at91sam7 sector erase reworked (thanks to Pavel Chromy) - merge consecutive sections during flash image write to work around possible section alignment issues with LPC2000 targets git-svn-id: svn://svn.berlios.de/openocd/trunk@194 b42882b7-edfa-0310-969c-e2dbd0fdcd60
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index c8e7c81d..6e72a612 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -19,6 +19,9 @@ endif
if FT2232_LIBFTDI
FTDI2232LIB = -lftdi
else
+if PRESTO_LIBFTDI
+FTDI2232LIB = -lftdi
+endif
FTDI2232LIB =
endif
@@ -41,7 +44,7 @@ endif
if FT2232_FTD2XX
FTD2XXLIB = $(FTD2XXLDADD)
else
-if PRESTO
+if PRESTO_FTD2XX
FTD2XXLIB = $(FTD2XXLDADD)
else
FTD2XXLIB =