summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorntfreak <ntfreak@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2008-07-12 16:25:17 +0000
committerntfreak <ntfreak@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2008-07-12 16:25:17 +0000
commit2e832a399a10fc00253b342f8cde9c5b1062fa63 (patch)
treeb679dc6381c72dc78e9c483c3399ae270c6dfa77 /src/Makefile.am
parentcebfbfa661b4e53cabf23bbb32c227e0b1962c77 (diff)
downloadopenocd+libswd-2e832a399a10fc00253b342f8cde9c5b1062fa63.tar.gz
openocd+libswd-2e832a399a10fc00253b342f8cde9c5b1062fa63.tar.bz2
openocd+libswd-2e832a399a10fc00253b342f8cde9c5b1062fa63.tar.xz
openocd+libswd-2e832a399a10fc00253b342f8cde9c5b1062fa63.zip
- remove requirement for file2c.tcl
git-svn-id: svn://svn.berlios.de/openocd/trunk@800 b42882b7-edfa-0310-969c-e2dbd0fdcd60
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am12
1 files changed, 5 insertions, 7 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 20b64251..2f1a2211 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -6,7 +6,7 @@ else
MAINFILE = main.c jim.c
endif
-openocd_SOURCES = $(MAINFILE) openocd.c startup.c
+openocd_SOURCES = $(MAINFILE) openocd.c
# set the include path found by configure
INCLUDES = -I$(top_srcdir)/src -I$(top_srcdir)/src/helper \
@@ -70,7 +70,7 @@ FTD2XXLIB =
endif
endif
-openocd_LDADD = $(top_builddir)/src/xsvf/libxsvf.a \
+openocd_LDADD = $(top_builddir)/src/startup.o $(top_builddir)/src/xsvf/libxsvf.a \
$(top_builddir)/src/target/libtarget.a $(top_builddir)/src/jtag/libjtag.a \
$(top_builddir)/src/helper/libhelper.a \
$(top_builddir)/src/server/libserver.a $(top_builddir)/src/helper/libhelper.a \
@@ -96,9 +96,7 @@ nobase_dist_pkglib_DATA = \
tcl/mmr_helpers.tcl \
tcl/readable.tcl
-# Convert .tcl to .c file
-startup.c: $(top_srcdir)/src/startup.tcl Makefile $(top_srcdir)/src/file2c.tcl
- ${TCLSH} $(top_srcdir)/src/file2c.tcl $(top_srcdir)/src/startup.tcl startup.c
+# Convert .tcl to object
-# add startup.c to make clean list
-CLEANFILES = startup.c
+$(top_builddir)/src/startup.o: $(top_srcdir)/src/startup.tcl
+ ${OBJCOPY} -I binary -O ${OBJCOPY_FORMAT} -B ${OBJCOPY_ARCH} startup.tcl startup.o