summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorduane <duane@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2009-06-24 02:00:19 +0000
committerduane <duane@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2009-06-24 02:00:19 +0000
commit30814c29048f59b4f6e9f605ea5dfd9ee246dad9 (patch)
tree25a3c479168feb43134222303557e1d67c4749c6 /src/Makefile.am
parent176b5600ed2a9a2653ec2b078dc417d3e8955a8e (diff)
downloadopenocd+libswd-30814c29048f59b4f6e9f605ea5dfd9ee246dad9.tar.gz
openocd+libswd-30814c29048f59b4f6e9f605ea5dfd9ee246dad9.tar.bz2
openocd+libswd-30814c29048f59b4f6e9f605ea5dfd9ee246dad9.tar.xz
openocd+libswd-30814c29048f59b4f6e9f605ea5dfd9ee246dad9.zip
Add quick target - full cygwin builds take a long long long time, this shortens the edit/build/debug cycle
git-svn-id: svn://svn.berlios.de/openocd/trunk@2382 b42882b7-edfa-0310-969c-e2dbd0fdcd60
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index c9b265d2..dc9b44c0 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -90,3 +90,13 @@ libopenocd_la_LIBADD += -lmicrohttpd
endif
MAINTAINERCLEANFILES = $(srcdir)/Makefile.in
+
+# The "quick" target builds executables & reinstalls the executables
+# Primary use: developer types to quicken the edit/compile/debug
+# cycle. by not requiring a "full build and full install". Note the
+# assumption is: You are only rebuilding the EXE.... and everything
+# else is/was previously installed.
+#
+# use at your own risk
+quick: all install-binPROGRAMS
+