summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorZachary T Welch <zw@superlucidity.net>2009-11-14 07:29:16 -0800
committerZachary T Welch <zw@superlucidity.net>2009-11-14 07:29:16 -0800
commit4088b1e622cff0673f2859de5ee611da736bdba7 (patch)
tree7049a500c42efee0071b9838a08e5a84478e7ea3 /src/Makefile.am
parentab3bdfb2cb7b0c16800195951e4ee549cf8e86a5 (diff)
downloadopenocd+libswd-4088b1e622cff0673f2859de5ee611da736bdba7.tar.gz
openocd+libswd-4088b1e622cff0673f2859de5ee611da736bdba7.tar.bz2
openocd+libswd-4088b1e622cff0673f2859de5ee611da736bdba7.tar.xz
openocd+libswd-4088b1e622cff0673f2859de5ee611da736bdba7.zip
add openocd.h for top-level declarations
Create src/openocd.h to hold declarations previously made internally by src/main.c and src/server/server.c. This ensures all functions are verified to be in-sync at compile time (rather than at link), making it easier to track down bugs.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 7721f340..77ae5ae2 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -16,6 +16,10 @@ libopenocd_la_SOURCES = \
hello.c \
openocd.c
+noinst_HEADERS = \
+ openocd.h
+
+
# set the include path found by configure
AM_CPPFLAGS = \
-I$(top_srcdir)/src \