summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorntfreak <ntfreak@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2008-07-11 18:25:21 +0000
committerntfreak <ntfreak@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2008-07-11 18:25:21 +0000
commit76dec044c02bb6d045c2e699501c8e07d75f6013 (patch)
tree355dbb415f86d1494e35c4c64731357a346e58af /src/Makefile.am
parent94966bf2e3933e308f3093a3fbf403ab83331ac5 (diff)
downloadopenocd+libswd-76dec044c02bb6d045c2e699501c8e07d75f6013.tar.gz
openocd+libswd-76dec044c02bb6d045c2e699501c8e07d75f6013.tar.bz2
openocd+libswd-76dec044c02bb6d045c2e699501c8e07d75f6013.tar.xz
openocd+libswd-76dec044c02bb6d045c2e699501c8e07d75f6013.zip
- configure check added for tclsh
- startup.c manually added to clean deps git-svn-id: svn://svn.berlios.de/openocd/trunk@796 b42882b7-edfa-0310-969c-e2dbd0fdcd60
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index fae00866..20b64251 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -6,7 +6,6 @@ else
MAINFILE = main.c jim.c
endif
-
openocd_SOURCES = $(MAINFILE) openocd.c startup.c
# set the include path found by configure
@@ -99,4 +98,7 @@ nobase_dist_pkglib_DATA = \
# Convert .tcl to .c file
startup.c: $(top_srcdir)/src/startup.tcl Makefile $(top_srcdir)/src/file2c.tcl
- tclsh $(top_srcdir)/src/file2c.tcl $(top_srcdir)/src/startup.tcl startup.c \ No newline at end of file
+ ${TCLSH} $(top_srcdir)/src/file2c.tcl $(top_srcdir)/src/startup.tcl startup.c
+
+# add startup.c to make clean list
+CLEANFILES = startup.c