summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorbodylove <bodylove@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2007-12-10 16:55:14 +0000
committerbodylove <bodylove@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2007-12-10 16:55:14 +0000
commit78d58dd16a276d5a3547d2f681f5062415736c85 (patch)
treeafc555af4f4921251c3c4db4640b100f25179ae0 /src/Makefile.am
parent9e6cec0dd3301395345777cfe2617559a868f2a9 (diff)
downloadopenocd+libswd-78d58dd16a276d5a3547d2f681f5062415736c85.tar.gz
openocd+libswd-78d58dd16a276d5a3547d2f681f5062415736c85.tar.bz2
openocd+libswd-78d58dd16a276d5a3547d2f681f5062415736c85.tar.xz
openocd+libswd-78d58dd16a276d5a3547d2f681f5062415736c85.zip
Changed openocd version info creation to be more useful.
- Now displays subversion revision and svn URL git-svn-id: svn://svn.berlios.de/openocd/trunk@220 b42882b7-edfa-0310-969c-e2dbd0fdcd60
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 512aade4..aa315506 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -6,6 +6,13 @@ INCLUDES = -I$(top_srcdir)/src/helper \
-I$(top_srcdir)/src/jtag -I$(top_srcdir)/src/target -I$(top_srcdir)/src/xsvf -I$(top_srcdir)/src/server \
-I$(top_srcdir)/src/flash -I$(top_srcdir)/src/pld $(all_includes)
+# pass path to prefix path
+openocd_CPPFLAGS = \
+ -DPKGLIBDIR=\"$(pkglibdir)\" \
+ -DPKGBLDDATE=\"`date +%F-%R`\" \
+ -DPKGBLDREV=\"`$(top_srcdir)/guess-rev.sh`\" \
+ @CPPFLAGS@
+
# the library search path.
openocd_LDFLAGS = $(all_libraries)
SUBDIRS = helper jtag xsvf target server flash pld