summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorBroadcom Corporation (Evan Hunter) <ehunter@broadcom.com>2011-04-14 10:25:01 +0200
committerØyvind Harboe <oyvind.harboe@zylin.com>2011-04-15 08:24:18 +0200
commitb69119668ed8d9633280f8b596fe9af60f51644b (patch)
tree68a8f525c679f6ce4a9a852b90116afa214329e0 /src/Makefile.am
parentf9feeacb7fa9b1f60d803708b831bde2187f29b5 (diff)
downloadopenocd+libswd-b69119668ed8d9633280f8b596fe9af60f51644b.tar.gz
openocd+libswd-b69119668ed8d9633280f8b596fe9af60f51644b.tar.bz2
openocd+libswd-b69119668ed8d9633280f8b596fe9af60f51644b.tar.xz
openocd+libswd-b69119668ed8d9633280f8b596fe9af60f51644b.zip
RTOS Thread awareness support wip
- works on Cortex-M3 with ThreadX and FreeRTOS Compared to original patch a few nits were fixed: - remove stricmp usage - unsigned compare fix - printf formatting fixes - fixed a bug with overrunning a memory buffer allocated with malloc.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 77449862..3d7b05f6 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -8,7 +8,8 @@ SUBDIRS = \
svf \
xsvf \
pld \
- server
+ server \
+ rtos
lib_LTLIBRARIES = libopenocd.la
bin_PROGRAMS = openocd
@@ -100,6 +101,7 @@ libopenocd_la_LIBADD = \
$(top_builddir)/src/flash/libflash.la \
$(top_builddir)/src/target/libtarget.la \
$(top_builddir)/src/server/libserver.la \
+ $(top_builddir)/src/rtos/librtos.la \
$(top_builddir)/src/helper/libhelper.la \
$(FTDI2232LIB) $(MINGWLDADD) $(LIBUSB)