summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authordrath <drath@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2006-11-22 13:03:10 +0000
committerdrath <drath@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2006-11-22 13:03:10 +0000
commite9297b40b994f071474210e7d9e224d50e25fcaf (patch)
treec04957b7721ab6825e73fad0775677643f82fc23 /src/Makefile.am
parent03e8f264f4c66baec9b86778d3488b23e0a8c0b6 (diff)
downloadopenocd+libswd-e9297b40b994f071474210e7d9e224d50e25fcaf.tar.gz
openocd+libswd-e9297b40b994f071474210e7d9e224d50e25fcaf.tar.bz2
openocd+libswd-e9297b40b994f071474210e7d9e224d50e25fcaf.tar.xz
openocd+libswd-e9297b40b994f071474210e7d9e224d50e25fcaf.zip
- added a PLD (programmable logic device) subsystem for FPGA, CPLD etc. configuration
- added support for loading .bit files into Xilinx Virtex-II devices - added support for the Gateworks GW16012 JTAG dongle - merged CFI fixes from XScale branch - a few minor fixes git-svn-id: svn://svn.berlios.de/openocd/trunk@116 b42882b7-edfa-0310-969c-e2dbd0fdcd60
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 208041f1..46714979 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -4,11 +4,11 @@ openocd_SOURCES = openocd.c
# set the include path found by configure
INCLUDES = -I$(top_srcdir)/src/helper \
-I$(top_srcdir)/src/jtag -I$(top_srcdir)/src/target -I$(top_srcdir)/src/xsvf -I$(top_srcdir)/src/server \
- -I$(top_srcdir)/src/flash $(all_includes)
+ -I$(top_srcdir)/src/flash -I$(top_srcdir)/src/pld $(all_includes)
# the library search path.
openocd_LDFLAGS = $(all_libraries)
-SUBDIRS = helper jtag xsvf target server flash
+SUBDIRS = helper jtag xsvf target server flash pld
if IS_MINGW
MINGWLDADD = -lwsock32
@@ -43,4 +43,5 @@ openocd_LDADD = $(top_builddir)/src/xsvf/libxsvf.a \
$(top_builddir)/src/helper/libhelper.a \
$(top_builddir)/src/server/libserver.a $(top_builddir)/src/helper/libhelper.a \
$(top_builddir)/src/flash/libflash.a $(top_builddir)/src/target/libtarget.a \
+ $(top_builddir)/src/pld/libpld.a \
$(FTDI2232LIB) $(FTD2XXLIB) $(MINGWLDADD)