summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authoroharboe <oharboe@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2008-07-11 06:44:22 +0000
committeroharboe <oharboe@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2008-07-11 06:44:22 +0000
commitefc6063df873b3419010ad66d183b997d52e630c (patch)
treea47636c216015a530f0fb3adc05bac8a6ad3f8d5 /src/Makefile.am
parent2b3f4fd293398f1868f8bad864f68f6ffec12ada (diff)
downloadopenocd+libswd-efc6063df873b3419010ad66d183b997d52e630c.tar.gz
openocd+libswd-efc6063df873b3419010ad66d183b997d52e630c.tar.bz2
openocd+libswd-efc6063df873b3419010ad66d183b997d52e630c.tar.xz
openocd+libswd-efc6063df873b3419010ad66d183b997d52e630c.zip
startup.tcl (former commands.tcl) is now embedded into OpenOCD executable.
git-svn-id: svn://svn.berlios.de/openocd/trunk@787 b42882b7-edfa-0310-969c-e2dbd0fdcd60
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index ff0eb6e5..1c96fb47 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -7,7 +7,7 @@ MAINFILE = main.c jim.c
endif
-openocd_SOURCES = $(MAINFILE) openocd.c
+openocd_SOURCES = $(MAINFILE) openocd.c startup.c
# set the include path found by configure
INCLUDES = -I$(top_srcdir)/src/helper \
@@ -82,7 +82,6 @@ openocd_LDADD = $(top_builddir)/src/xsvf/libxsvf.a \
nobase_dist_pkglib_DATA = \
- tcl/commands.tcl \
tcl/bitsbytes.tcl \
tcl/chip/atmel/at91/aic.tcl \
tcl/chip/atmel/at91/at91sam7x128.tcl \
@@ -98,3 +97,6 @@ nobase_dist_pkglib_DATA = \
tcl/mmr_helpers.tcl \
tcl/readable.tcl
+# Convert .tcl to .c file
+startup.c: $(top_srcdir)/src/startup.tcl Makefile $(top_srcdir)/src/file2c.tcl
+ tclsh $(top_srcdir)/src/file2c.tcl $(top_srcdir)/src/startup.tcl startup.c \ No newline at end of file