summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorduane <duane@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2008-12-27 01:15:50 +0000
committerduane <duane@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2008-12-27 01:15:50 +0000
commitf7274784a22e975dbab6a8b24770b652a813e64d (patch)
tree72f5c7d3c22aff2ee18bbff753e939c1b695d071 /src/Makefile.am
parent437a981878d450baf31081506f6ec9005c43a9fb (diff)
downloadopenocd+libswd-f7274784a22e975dbab6a8b24770b652a813e64d.tar.gz
openocd+libswd-f7274784a22e975dbab6a8b24770b652a813e64d.tar.bz2
openocd+libswd-f7274784a22e975dbab6a8b24770b652a813e64d.tar.xz
openocd+libswd-f7274784a22e975dbab6a8b24770b652a813e64d.zip
Build Permutations with ftd2xx and libftdi addressed. Also added a new se of regression makefiles to build openocd in multiple ways
git-svn-id: svn://svn.berlios.de/openocd/trunk@1275 b42882b7-edfa-0310-969c-e2dbd0fdcd60
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am22
1 files changed, 2 insertions, 20 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 6a9f62a8..b2542917 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -55,25 +55,7 @@ endif
endif
endif
-if IS_WIN32
-if FTD2XXDIR
-FTD2XXLDADD = @WITH_FTD2XX@/FTD2XX.lib
-else
-FTD2XXLDADD = -lftd2xx
-endif
-else
-FTD2XXLDADD = -lftd2xx
-endif
-
-if FT2232_FTD2XX
-FTD2XXLIB = $(FTD2XXLDADD)
-else
-if PRESTO_FTD2XX
-FTD2XXLIB = $(FTD2XXLDADD)
-else
-FTD2XXLIB =
-endif
-endif
+
openocd_LDADD = $(top_builddir)/src/xsvf/libxsvf.a \
$(top_builddir)/src/target/libtarget.a $(top_builddir)/src/jtag/libjtag.a \
@@ -81,7 +63,7 @@ openocd_LDADD = $(top_builddir)/src/xsvf/libxsvf.a \
$(top_builddir)/src/server/libserver.a $(top_builddir)/src/helper/libhelper.a \
$(top_builddir)/src/flash/libflash.a $(top_builddir)/src/target/libtarget.a \
$(top_builddir)/src/pld/libpld.a \
- $(FTDI2232LIB) $(FTD2XXLIB) $(MINGWLDADD) $(LIBUSB)
+ $(FTDI2232LIB) $(MINGWLDADD) $(LIBUSB)
if HTTPD