summaryrefslogtreecommitdiff
path: root/src/flash/Makefile.am
diff options
context:
space:
mode:
authorzwelch <zwelch@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2009-05-10 22:03:57 +0000
committerzwelch <zwelch@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2009-05-10 22:03:57 +0000
commit647e61cc6d9b13dd2799d2302ce9289a1627e36c (patch)
tree5172bfbe4df60948bf6d61ebea28366a51c03c12 /src/flash/Makefile.am
parent104580e0bfb5aa2f79bc6c4c96935a8832f5f787 (diff)
downloadopenocd+libswd-647e61cc6d9b13dd2799d2302ce9289a1627e36c.tar.gz
openocd+libswd-647e61cc6d9b13dd2799d2302ce9289a1627e36c.tar.bz2
openocd+libswd-647e61cc6d9b13dd2799d2302ce9289a1627e36c.tar.xz
openocd+libswd-647e61cc6d9b13dd2799d2302ce9289a1627e36c.zip
Extend autotools build to create shared library libopenocd with libtool:
- Add libtoolize step too bootstrap script; creates ltmain.sh script. - Add AC_PROG_LIBTOOL to configure.in to add libtool support to build. - Change Makefile.am library rules from static (_a) to libtool (_la). - Install libopenocd.{la,so,a} in $(libdir); update openocd link rules. - Extend MAINTAINERCLEANFILES in top-level Makefile.am to remove ltmain.sh. git-svn-id: svn://svn.berlios.de/openocd/trunk@1695 b42882b7-edfa-0310-969c-e2dbd0fdcd60
Diffstat (limited to 'src/flash/Makefile.am')
-rw-r--r--src/flash/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/flash/Makefile.am b/src/flash/Makefile.am
index db24001a..7895edc8 100644
--- a/src/flash/Makefile.am
+++ b/src/flash/Makefile.am
@@ -4,8 +4,8 @@ AM_CPPFLAGS = \
-I$(top_srcdir)/src/target
METASOURCES = AUTO
-noinst_LIBRARIES = libflash.a
-libflash_a_SOURCES = \
+noinst_LTLIBRARIES = libflash.la
+libflash_la_SOURCES = \
flash.c lpc2000.c cfi.c non_cfi.c at91sam7.c \
str7x.c str9x.c aduc702x.c nand.c nand_ecc.c \
lpc3180_nand_controller.c stellaris.c str9xpec.c stm32x.c tms470.c \