summaryrefslogtreecommitdiff
path: root/src/flash/Makefile.am
diff options
context:
space:
mode:
authorZachary T Welch <zw@superlucidity.net>2009-11-17 13:04:49 -0800
committerZachary T Welch <zw@superlucidity.net>2009-11-19 13:39:41 -0800
commit870b8c04557f0b7441cc502debaf537984d77e2a (patch)
tree38f868b2f6f76890f35e794937e8cccb834e2a66 /src/flash/Makefile.am
parent8f446fcf676e9cd13cf53d9946f0cae5d29a10ec (diff)
downloadopenocd+libswd-870b8c04557f0b7441cc502debaf537984d77e2a.tar.gz
openocd+libswd-870b8c04557f0b7441cc502debaf537984d77e2a.tar.bz2
openocd+libswd-870b8c04557f0b7441cc502debaf537984d77e2a.tar.xz
openocd+libswd-870b8c04557f0b7441cc502debaf537984d77e2a.zip
allow flash/nand banks commands to accept names
Add get_flash_bank_by_name (and get_nand_device_by_name) helpers to retrieves struct flash_bank * (struct nand_device *) given a driver name and an (optional) driver-specific bank index. These are used to extend flash_command_get_bank_by_num (and nand_command_get_device_by_num) to allow all flash (nand) commands to reference defined banks by name, not just by number. To avoid some code duplication, add the flash/common.[ch] files to hold functionality common to both types driver. The first two methods are helpers for the above routines to find a bank specified by a "name" or "name.index" string. get_flash_name_index() finds the '.index' portion, while flash_driver_name_matches() performs the string portion matching.
Diffstat (limited to 'src/flash/Makefile.am')
-rw-r--r--src/flash/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/flash/Makefile.am b/src/flash/Makefile.am
index b687182d..84032302 100644
--- a/src/flash/Makefile.am
+++ b/src/flash/Makefile.am
@@ -11,6 +11,7 @@ libflash_la_SOURCES = \
mflash.c
FLASH_SRCS = \
+ common.c \
cfi.c \
non_cfi.c \
faux.c \
@@ -60,6 +61,7 @@ noinst_HEADERS = \
at91sam3.h \
avrf.h \
cfi.h \
+ common.h \
flash.h \
lpc2000.h \
lpc288x.h \