summaryrefslogtreecommitdiff
path: root/src/flash/Makefile.am
diff options
context:
space:
mode:
authorntfreak <ntfreak@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2007-06-24 15:04:07 +0000
committerntfreak <ntfreak@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2007-06-24 15:04:07 +0000
commit8c290412d28f9eef568dac0cfc20ccd4a9eca4d5 (patch)
tree40f5da0e30044422956cce2511c936e9af8bca12 /src/flash/Makefile.am
parentffb51c23fdd753ada2554b8b6283533089153b46 (diff)
downloadopenocd+libswd-8c290412d28f9eef568dac0cfc20ccd4a9eca4d5.tar.gz
openocd+libswd-8c290412d28f9eef568dac0cfc20ccd4a9eca4d5.tar.bz2
openocd+libswd-8c290412d28f9eef568dac0cfc20ccd4a9eca4d5.tar.xz
openocd+libswd-8c290412d28f9eef568dac0cfc20ccd4a9eca4d5.zip
- ST STM32x cortex support added
- ST STM32x flash support added - cleaned up armv7m and cortex-m3 support, removed luminary specific code - cortex-m3 16bit read/write added (required for STM32x flash programming) git-svn-id: svn://svn.berlios.de/openocd/trunk@177 b42882b7-edfa-0310-969c-e2dbd0fdcd60
Diffstat (limited to 'src/flash/Makefile.am')
-rw-r--r--src/flash/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/flash/Makefile.am b/src/flash/Makefile.am
index 7b5c5222..76c8c180 100644
--- a/src/flash/Makefile.am
+++ b/src/flash/Makefile.am
@@ -1,5 +1,7 @@
INCLUDES = -I$(top_srcdir)/src/helper -I$(top_srcdir)/src/jtag -I$(top_srcdir)/src/target $(all_includes)
METASOURCES = AUTO
noinst_LIBRARIES = libflash.a
-libflash_a_SOURCES = flash.c lpc2000.c cfi.c non_cfi.c at91sam7.c str7x.c str9x.c nand.c lpc3180_nand_controller.c stellaris.c str9xpec.c
-noinst_HEADERS = flash.h lpc2000.h cfi.h non_cfi.h at91sam7.h str7x.h str9x.h nand.h lpc3180_nand_controller.h stellaris.h str9xpec.h
+libflash_a_SOURCES = flash.c lpc2000.c cfi.c non_cfi.c at91sam7.c str7x.c str9x.c nand.c lpc3180_nand_controller.c \
+ stellaris.c str9xpec.c stm32x.c
+noinst_HEADERS = flash.h lpc2000.h cfi.h non_cfi.h at91sam7.h str7x.h str9x.h nand.h lpc3180_nand_controller.h \
+ stellaris.h str9xpec.h stm32x.h