summaryrefslogtreecommitdiff
path: root/src/flash/Makefile.am
diff options
context:
space:
mode:
authoroharboe <oharboe@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2009-09-03 08:23:39 +0000
committeroharboe <oharboe@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2009-09-03 08:23:39 +0000
commita89dd2ca6542d157890656d918d6ae2f933ab401 (patch)
tree042f98ba0659b4602aaccf69571208e10cb1ff30 /src/flash/Makefile.am
parent3878b1279399cbd1c57730f7410db4b7c01b15c4 (diff)
downloadopenocd+libswd-a89dd2ca6542d157890656d918d6ae2f933ab401.tar.gz
openocd+libswd-a89dd2ca6542d157890656d918d6ae2f933ab401.tar.bz2
openocd+libswd-a89dd2ca6542d157890656d918d6ae2f933ab401.tar.xz
openocd+libswd-a89dd2ca6542d157890656d918d6ae2f933ab401.zip
David Brownell
Abstract the orion_nand_fast_block_write() routine into a separate routine -- arm_nandwrite() -- so that other ARM cores can reuse it. Have davinci_nand do so. This faster than byte-at-a-time ops by a factor of three (!), even given the slowish interactions to support hardware ECC (1-bit flavor in that test) each 512 bytes; those could be read more efficiently by on-chip code. NOTE that until there's a generic "ARM algorithm" structure, this can't work on newer ARMv6 (like ARM1136) or ARMv7A (like Cortex-A8) cores, though the downloaded code itself would work just fine there. git-svn-id: svn://svn.berlios.de/openocd/trunk@2663 b42882b7-edfa-0310-969c-e2dbd0fdcd60
Diffstat (limited to 'src/flash/Makefile.am')
-rw-r--r--src/flash/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/flash/Makefile.am b/src/flash/Makefile.am
index 60a322aa..bf39b2e4 100644
--- a/src/flash/Makefile.am
+++ b/src/flash/Makefile.am
@@ -6,6 +6,7 @@ AM_CPPFLAGS = \
METASOURCES = AUTO
noinst_LTLIBRARIES = libflash.la
libflash_la_SOURCES = \
+ arm_nandio.c \
flash.c \
lpc2000.c \
cfi.c \
@@ -38,6 +39,7 @@ libflash_la_SOURCES = \
avrf.c
noinst_HEADERS = \
+ arm_nandio.h \
flash.h \
lpc2000.h \
cfi.h \