summaryrefslogtreecommitdiff
path: root/src/flash/Makefile.am
diff options
context:
space:
mode:
authorzwelch <zwelch@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2009-05-24 01:38:19 +0000
committerzwelch <zwelch@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2009-05-24 01:38:19 +0000
commitc0fc8f93f1eabe8a4adfed7784b1416b257cf035 (patch)
tree1debbd47835a726ccc41ea6150f6844247697fdc /src/flash/Makefile.am
parent67dd29a4af1271c77f2f8c3389d5852d8da4e6c3 (diff)
downloadopenocd+libswd-c0fc8f93f1eabe8a4adfed7784b1416b257cf035.tar.gz
openocd+libswd-c0fc8f93f1eabe8a4adfed7784b1416b257cf035.tar.bz2
openocd+libswd-c0fc8f93f1eabe8a4adfed7784b1416b257cf035.tar.xz
openocd+libswd-c0fc8f93f1eabe8a4adfed7784b1416b257cf035.zip
David Brownell <david-b@pacbell.net>:
NAND support for DaVinci-family drivers, with HW ECC support. Declare the NAND chip on the DM355 EVM board. Currently tested on DM355 for Linux interop using the standard large page (2KB) chip in the EVM socket; "hwecc1" and "hwecc4" work fine. (Using hwecc4 relies on patches that haven't quite made it through the Linux-MTD bottlenecks yet.) Not yet tested: 1-bit on small-page (although it's hard to see how that could fail); 4-bit on small page (picky layout issues); the "hwecc_infix" mode (primarily for older boot ROMs; testing there is blocked on having new bootloader code). git-svn-id: svn://svn.berlios.de/openocd/trunk@1903 b42882b7-edfa-0310-969c-e2dbd0fdcd60
Diffstat (limited to 'src/flash/Makefile.am')
-rw-r--r--src/flash/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/flash/Makefile.am b/src/flash/Makefile.am
index e5b76cb6..64fc54f5 100644
--- a/src/flash/Makefile.am
+++ b/src/flash/Makefile.am
@@ -6,7 +6,7 @@ AM_CPPFLAGS = \
METASOURCES = AUTO
noinst_LTLIBRARIES = libflash.la
libflash_la_SOURCES = \
- flash.c lpc2000.c cfi.c non_cfi.c at91sam7.c \
+ flash.c lpc2000.c cfi.c non_cfi.c at91sam7.c davinci_nand.c \
str7x.c str9x.c aduc702x.c nand.c nand_ecc.c nand_ecc_kw.c \
lpc3180_nand_controller.c stellaris.c str9xpec.c stm32x.c tms470.c \
ecos.c orion_nand.c s3c24xx_nand.c s3c2410_nand.c s3c2412_nand.c \