summaryrefslogtreecommitdiff
path: root/src/flash/Makefile.am
diff options
context:
space:
mode:
authordrath <drath@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2007-03-15 13:36:44 +0000
committerdrath <drath@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2007-03-15 13:36:44 +0000
commitcb582796539d35920e918bec2d0118eb3736d40e (patch)
tree0c46f343c31094c65d196c66cc821e0a6d43bf49 /src/flash/Makefile.am
parente0c2e30660bef422744e885ab32c26c58978a8a1 (diff)
downloadopenocd+libswd-cb582796539d35920e918bec2d0118eb3736d40e.tar.gz
openocd+libswd-cb582796539d35920e918bec2d0118eb3736d40e.tar.bz2
openocd+libswd-cb582796539d35920e918bec2d0118eb3736d40e.tar.xz
openocd+libswd-cb582796539d35920e918bec2d0118eb3736d40e.zip
- reworked file i/o. every fileaccess (target, flash, nand, in future configuration, too) should now go through the fileio subsystem
- added support for reading IHEX files (through fileio) - load/dump_binary renamed to the more generic load/dump_image <file> <address> ['bin'|'ihex'] - added NAND framework (preliminary) - added support for the LPC3180 SLC and MLC NAND controllers (preliminary) - fix initialization for parport - gw16012 fixes/cleanups - added EmbeddedICE version 7 (preliminary, reported on two LPC23xx devices so far) - added 'arm7_9 etm <target#>' configuration command to enable access to the ETM registers git-svn-id: svn://svn.berlios.de/openocd/trunk@132 b42882b7-edfa-0310-969c-e2dbd0fdcd60
Diffstat (limited to 'src/flash/Makefile.am')
-rw-r--r--src/flash/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/flash/Makefile.am b/src/flash/Makefile.am
index 65692e3a..6368f626 100644
--- a/src/flash/Makefile.am
+++ b/src/flash/Makefile.am
@@ -1,5 +1,5 @@
INCLUDES = -I$(top_srcdir)/src/helper -I$(top_srcdir)/src/jtag -I$(top_srcdir)/src/target $(all_includes)
METASOURCES = AUTO
noinst_LIBRARIES = libflash.a
-libflash_a_SOURCES = flash.c lpc2000.c cfi.c at91sam7.c str7x.c str9x.c
-noinst_HEADERS = flash.h lpc2000.h cfi.h at91sam7.h str7x.h str9x.h
+libflash_a_SOURCES = flash.c lpc2000.c cfi.c at91sam7.c str7x.c str9x.c nand.c lpc3180_nand_controller.c
+noinst_HEADERS = flash.h lpc2000.h cfi.h at91sam7.h str7x.h str9x.h nand.h lpc3180_nand_controller.h