summaryrefslogtreecommitdiff
path: root/src/flash/Makefile.am
diff options
context:
space:
mode:
authoroharboe <oharboe@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2009-04-02 21:23:05 +0000
committeroharboe <oharboe@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2009-04-02 21:23:05 +0000
commitf481deb58f586a72fc38253bbf89618a3611e4cc (patch)
treec4760123b407bf266ea21becf91f5c6eb775a11e /src/flash/Makefile.am
parent3f427b90e062a5bae22322986b6053d64f831234 (diff)
downloadopenocd+libswd-f481deb58f586a72fc38253bbf89618a3611e4cc.tar.gz
openocd+libswd-f481deb58f586a72fc38253bbf89618a3611e4cc.tar.bz2
openocd+libswd-f481deb58f586a72fc38253bbf89618a3611e4cc.tar.xz
openocd+libswd-f481deb58f586a72fc38253bbf89618a3611e4cc.zip
Nicolas Pitre nico at cam.org software ECC computation for NAND flash
git-svn-id: svn://svn.berlios.de/openocd/trunk@1444 b42882b7-edfa-0310-969c-e2dbd0fdcd60
Diffstat (limited to 'src/flash/Makefile.am')
-rw-r--r--src/flash/Makefile.am18
1 files changed, 11 insertions, 7 deletions
diff --git a/src/flash/Makefile.am b/src/flash/Makefile.am
index 9d7746cd..7e57386b 100644
--- a/src/flash/Makefile.am
+++ b/src/flash/Makefile.am
@@ -2,11 +2,15 @@ INCLUDES = -I$(top_srcdir)/src/helper -I$(top_srcdir)/src/jtag -I$(top_srcdir)/s
AM_CPPFLAGS = -DPKGLIBDIR=\"$(pkglibdir)\" @CPPFLAGS@
METASOURCES = AUTO
noinst_LIBRARIES = libflash.a
-libflash_a_SOURCES = flash.c lpc2000.c cfi.c non_cfi.c at91sam7.c at91sam7_old.c str7x.c str9x.c aduc702x.c nand.c lpc3180_nand_controller.c \
- stellaris.c str9xpec.c stm32x.c tms470.c ecos.c orion_nand.c \
- s3c24xx_nand.c s3c2410_nand.c s3c2412_nand.c s3c2440_nand.c s3c2443_nand.c lpc288x.c ocl.c mflash.c pic32mx.c
-noinst_HEADERS = flash.h lpc2000.h cfi.h non_cfi.h at91sam7.h at91sam7_old.h str7x.h str9x.h nand.h lpc3180_nand_controller.h \
- stellaris.h str9xpec.h stm32x.h tms470.h s3c24xx_nand.h s3c24xx_regs_nand.h lpc288x.h mflash.h \
- ocl.h pic32mx.h
-
+libflash_a_SOURCES = \
+ flash.c lpc2000.c cfi.c non_cfi.c at91sam7.c at91sam7_old.c \
+ str7x.c str9x.c aduc702x.c nand.c nand_ecc.c \
+ lpc3180_nand_controller.c stellaris.c str9xpec.c stm32x.c tms470.c \
+ ecos.c orion_nand.c s3c24xx_nand.c s3c2410_nand.c s3c2412_nand.c \
+ s3c2440_nand.c s3c2443_nand.c lpc288x.c ocl.c mflash.c pic32mx.c
+noinst_HEADERS = \
+ flash.h lpc2000.h cfi.h non_cfi.h at91sam7.h at91sam7_old.h str7x.h \
+ str9x.h nand.h lpc3180_nand_controller.h stellaris.h str9xpec.h \
+ stm32x.h tms470.h s3c24xx_nand.h s3c24xx_regs_nand.h lpc288x.h \
+ mflash.h ocl.h pic32mx.h
MAINTAINERCLEANFILES = Makefile.in