summaryrefslogtreecommitdiff
path: root/src/flash/nand/Makefile.am
diff options
context:
space:
mode:
authorDean Glazeski <dnglaze@gmail.com>2009-12-09 12:40:54 -0600
committerDavid Brownell <dbrownell@users.sourceforge.net>2009-12-19 13:26:33 -0800
commit3ac2a440419a52752a5e11eba8ab2722a1fe73bf (patch)
treec2b9cc1b558654e26cdc146431e4504c2f32e757 /src/flash/nand/Makefile.am
parent28f8e9dfb7bfaf87957c95790c3ffe5d9fbd8834 (diff)
downloadopenocd+libswd-3ac2a440419a52752a5e11eba8ab2722a1fe73bf.tar.gz
openocd+libswd-3ac2a440419a52752a5e11eba8ab2722a1fe73bf.tar.bz2
openocd+libswd-3ac2a440419a52752a5e11eba8ab2722a1fe73bf.tar.xz
openocd+libswd-3ac2a440419a52752a5e11eba8ab2722a1fe73bf.zip
AT91SAM9 NAND flash driver.
This creates the TCL interface for configuring an AT91SAM9 NAND flash controller and implements the necessary functions to correctly work with a NAND flash device connected to the chip. This includes updates to the driver list and the Makefile.am to support building the driver and also houses the documentation update in openocd.texi. Signed-off-by: David Brownell <dbrownell@users.sourceforge.net>
Diffstat (limited to 'src/flash/nand/Makefile.am')
-rw-r--r--src/flash/nand/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/flash/nand/Makefile.am b/src/flash/nand/Makefile.am
index f3033b85..bb9998e5 100644
--- a/src/flash/nand/Makefile.am
+++ b/src/flash/nand/Makefile.am
@@ -24,7 +24,8 @@ NAND_DRIVERS = \
s3c2410.c \
s3c2412.c \
s3c2440.c \
- s3c2443.c
+ s3c2443.c \
+ at91sam9.c
noinst_HEADERS = \
arm_io.h \