summaryrefslogtreecommitdiff
path: root/src/flash/nand/Makefile.am
diff options
context:
space:
mode:
authorBjarne Steinsbo <bsteinsbo@gmail.com>2011-02-15 20:23:40 +0100
committerØyvind Harboe <oyvind.harboe@zylin.com>2011-02-15 20:23:40 +0100
commit3f4b9e334b867a16c35b1c6d9a1f9aefd35fd91b (patch)
tree3b599ba715c6f74ffdc07d93a22e9dc950f2a50f /src/flash/nand/Makefile.am
parentfe0894015fd3d25593ce3a7211b1540ebfbab1f3 (diff)
downloadopenocd+libswd-3f4b9e334b867a16c35b1c6d9a1f9aefd35fd91b.tar.gz
openocd+libswd-3f4b9e334b867a16c35b1c6d9a1f9aefd35fd91b.tar.bz2
openocd+libswd-3f4b9e334b867a16c35b1c6d9a1f9aefd35fd91b.tar.xz
openocd+libswd-3f4b9e334b867a16c35b1c6d9a1f9aefd35fd91b.zip
lpc32xx: Flash driver
Based on the lpc3180 driver, but released as a separate driver for two reasons: 1) I don't have an lpc3180 to test it against, so it might unintentionally break compatibility. 2) It's using a different OOB layout than lpc3180. Rewritten so that it no longer borrows code from the NXP CDL library. Instead borrowing code from the u-boot port to lpc32xx, written by Kevin Wells. Tested on lpc3250 (Hitex LPC3250-Stick). OOB layout is compatible with LPCLinux.
Diffstat (limited to 'src/flash/nand/Makefile.am')
-rw-r--r--src/flash/nand/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/flash/nand/Makefile.am b/src/flash/nand/Makefile.am
index 9aa0e69f..23c303bf 100644
--- a/src/flash/nand/Makefile.am
+++ b/src/flash/nand/Makefile.am
@@ -16,6 +16,7 @@ NAND_DRIVERS = \
nonce.c \
davinci.c \
lpc3180.c \
+ lpc32xx.c \
mx2.c \
mx3.c \
orion.c \
@@ -35,6 +36,7 @@ noinst_HEADERS = \
fileio.h \
imp.h \
lpc3180.h \
+ lpc32xx.h \
mx2.h \
mx3.h \
s3c24xx.h \