summaryrefslogtreecommitdiff
path: root/src/flash/nand/Makefile.am
diff options
context:
space:
mode:
authorgcembed <gcembed@gmail.com>2010-05-20 08:25:09 +0200
committerØyvind Harboe <oyvind.harboe@zylin.com>2010-05-20 08:28:36 +0200
commitf40faeb349e417e566bf100aa08a9246501a82c5 (patch)
tree279cccee11a49e48cf47efd5fcd7d68f75d3cbe8 /src/flash/nand/Makefile.am
parent8465e9944291a03a216fa15e0d7ed6eb9d44ba92 (diff)
downloadopenocd+libswd-f40faeb349e417e566bf100aa08a9246501a82c5.tar.gz
openocd+libswd-f40faeb349e417e566bf100aa08a9246501a82c5.tar.bz2
openocd+libswd-f40faeb349e417e566bf100aa08a9246501a82c5.tar.xz
openocd+libswd-f40faeb349e417e566bf100aa08a9246501a82c5.zip
nand : Add Freescale iMX27 nand flash controller support
This patch add support of iMX27 nand flash controller. This is based on driver for imx31 nand flash controller. OOB functionality is not fully working. As in mx31 controller, mx2 NFC has a bug that swap two bytes between SPARE and MAIN buffer. I used this driver for several months and no problems appear.
Diffstat (limited to 'src/flash/nand/Makefile.am')
-rw-r--r--src/flash/nand/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/flash/nand/Makefile.am b/src/flash/nand/Makefile.am
index a495dfdc..259a9cb6 100644
--- a/src/flash/nand/Makefile.am
+++ b/src/flash/nand/Makefile.am
@@ -18,6 +18,7 @@ NAND_DRIVERS = \
nonce.c \
davinci.c \
lpc3180.c \
+ mx2.c \
mx3.c \
orion.c \
s3c24xx.c \
@@ -35,6 +36,7 @@ noinst_HEADERS = \
fileio.h \
imp.h \
lpc3180.h \
+ mx2.h \
mx3.h \
s3c24xx.h \
s3c24xx_regs.h