summaryrefslogtreecommitdiff
path: root/src/flash/nor/Makefile.am
diff options
context:
space:
mode:
authorZachary T Welch <zw@superlucidity.net>2009-12-03 16:47:49 -0800
committerZachary T Welch <zw@superlucidity.net>2009-12-04 03:34:33 -0800
commit3cb0b56005059314c8d09d2f8574042a4352dab4 (patch)
tree021bf33159664a0d084d85b7b3cf64abe5745edf /src/flash/nor/Makefile.am
parent79a73a786ee0f95b49d86abbdea1e985049c5b1f (diff)
downloadopenocd+libswd-3cb0b56005059314c8d09d2f8574042a4352dab4.tar.gz
openocd+libswd-3cb0b56005059314c8d09d2f8574042a4352dab4.tar.bz2
openocd+libswd-3cb0b56005059314c8d09d2f8574042a4352dab4.tar.xz
openocd+libswd-3cb0b56005059314c8d09d2f8574042a4352dab4.zip
add flash/nor/{tcl.c,imp.h} from flash/flash.c
Moves the top-level 'flash' command handlers into flash/nor/tcl.c, with flash/nor/imp.h providing an internal implementation header to share non-public API components.
Diffstat (limited to 'src/flash/nor/Makefile.am')
-rw-r--r--src/flash/nor/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/flash/nor/Makefile.am b/src/flash/nor/Makefile.am
index 211366b8..ed9ebb30 100644
--- a/src/flash/nor/Makefile.am
+++ b/src/flash/nor/Makefile.am
@@ -2,6 +2,10 @@ AM_CPPFLAGS = -I$(top_srcdir)/src
noinst_LTLIBRARIES = libocdflashnor.la
libocdflashnor_la_SOURCES = \
+ tcl.c \
+ $(NOR_DRIVERS)
+
+NOR_DRIVERS = \
aduc702x.c \
at91sam3.c \
at91sam7.c \
@@ -27,6 +31,7 @@ noinst_HEADERS = \
at91sam3.h \
avrf.h \
cfi.h \
+ imp.h \
lpc2000.h \
lpc288x.h \
non_cfi.h \