summaryrefslogtreecommitdiff
path: root/src/helper/Makefile.am
diff options
context:
space:
mode:
authoroharboe <oharboe@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2008-03-11 21:32:03 +0000
committeroharboe <oharboe@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2008-03-11 21:32:03 +0000
commit0313c595555ae1c391766d1594735042ccd20443 (patch)
treec540c8c4ab3fdd31417f34197206bbb0787b92de /src/helper/Makefile.am
parentb9162dcc8e68413966c8493556e471fbdcb88a1f (diff)
downloadopenocd+libswd-0313c595555ae1c391766d1594735042ccd20443.tar.gz
openocd+libswd-0313c595555ae1c391766d1594735042ccd20443.tar.bz2
openocd+libswd-0313c595555ae1c391766d1594735042ccd20443.tar.xz
openocd+libswd-0313c595555ae1c391766d1594735042ccd20443.zip
reduce compare noise. If someone should be crazy enough to try to run OpenOCD under eCos, then they'v got some hooks to point them in the general direction.
git-svn-id: svn://svn.berlios.de/openocd/trunk@499 b42882b7-edfa-0310-969c-e2dbd0fdcd60
Diffstat (limited to 'src/helper/Makefile.am')
-rw-r--r--src/helper/Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/src/helper/Makefile.am b/src/helper/Makefile.am
index 91fe01b6..e518bc7f 100644
--- a/src/helper/Makefile.am
+++ b/src/helper/Makefile.am
@@ -2,7 +2,14 @@ INCLUDES = $(all_includes)
METASOURCES = AUTO
AM_CPPFLAGS = -DPKGDATADIR=\"$(pkgdatadir)\" -DPKGLIBDIR=\"$(pkglibdir)\" @CPPFLAGS@
noinst_LIBRARIES = libhelper.a
-libhelper_a_SOURCES = binarybuffer.c configuration.c options.c log.c interpreter.c command.c time_support.c \
+
+if ECOSBOARD
+CONFIGFILES =
+else
+CONFIGFILES = options.c
+endif
+
+libhelper_a_SOURCES = binarybuffer.c $(CONFIGFILES) configuration.c log.c interpreter.c command.c time_support.c \
replacements.c fileio.c
noinst_HEADERS = binarybuffer.h configuration.h types.h log.h command.h \
interpreter.h time_support.h replacements.h fileio.h