summaryrefslogtreecommitdiff
path: root/src/helper/Makefile.am
diff options
context:
space:
mode:
authorntfreak <ntfreak@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2008-07-18 11:38:23 +0000
committerntfreak <ntfreak@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2008-07-18 11:38:23 +0000
commit60ba4476dfef5fae48b85d54e376a3ca27442113 (patch)
treed830eeb18a83b51cb23f3fb672cb0587c4d92804 /src/helper/Makefile.am
parent722fcb8d61e98be3ec2be73f26e8c9ab2136d70c (diff)
downloadopenocd+libswd-60ba4476dfef5fae48b85d54e376a3ca27442113.tar.gz
openocd+libswd-60ba4476dfef5fae48b85d54e376a3ca27442113.tar.bz2
openocd+libswd-60ba4476dfef5fae48b85d54e376a3ca27442113.tar.xz
openocd+libswd-60ba4476dfef5fae48b85d54e376a3ca27442113.zip
- fix incorrectly registered function openocd_array2mem
- removed unused variables - reformatted lpc288x.[ch] - fixed helper/Makefile.am dependencies - add correct svn props to added files git-svn-id: svn://svn.berlios.de/openocd/trunk@829 b42882b7-edfa-0310-969c-e2dbd0fdcd60
Diffstat (limited to 'src/helper/Makefile.am')
-rw-r--r--src/helper/Makefile.am14
1 files changed, 6 insertions, 8 deletions
diff --git a/src/helper/Makefile.am b/src/helper/Makefile.am
index 2ba0a563..630fbf50 100644
--- a/src/helper/Makefile.am
+++ b/src/helper/Makefile.am
@@ -1,4 +1,4 @@
-INCLUDES = -I$(top_srcdir)/src $(all_includes)
+INCLUDES = -I$(top_srcdir)/src $(all_includes) -I$(top_srcdir)/src/target
METASOURCES = AUTO
AM_CPPFLAGS = -DPKGDATADIR=\"$(pkgdatadir)\" -DPKGLIBDIR=\"$(pkglibdir)\" @CPPFLAGS@
noinst_LIBRARIES = libhelper.a
@@ -10,20 +10,18 @@ CONFIGFILES = options.c jim.c
endif
libhelper_a_SOURCES = binarybuffer.c $(CONFIGFILES) configuration.c log.c command.c time_support.c \
- replacements.c fileio.c
-noinst_HEADERS = binarybuffer.h configuration.h types.h log.h command.h \
- time_support.h replacements.h fileio.h \
- jim.h
+ replacements.c fileio.c startup_tcl.c
-libhelper_a_SOURCES += startup_tcl.c
+noinst_HEADERS = binarybuffer.h configuration.h types.h log.h command.h \
+ time_support.h replacements.h fileio.h jim.h
noinst_PROGRAMS = bin2char
bin2char_SOURCES = bin2char.c
# Convert .tcl to cfile
-startup_tcl.c: bin2char startup.tcl
- ./bin2char startup_tcl < $(srcdir)/startup.tcl > startup_tcl.c
+startup_tcl.c: startup.tcl bin2char$(EXEEXT)
+ ./bin2char$(EXEEXT) startup_tcl < $(srcdir)/$< > $@
# add startup_tcl.c to make clean list
CLEANFILES = startup_tcl.c