summaryrefslogtreecommitdiff
path: root/src/helper/Makefile.am
diff options
context:
space:
mode:
authorzwelch <zwelch@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2009-05-10 22:03:57 +0000
committerzwelch <zwelch@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2009-05-10 22:03:57 +0000
commit647e61cc6d9b13dd2799d2302ce9289a1627e36c (patch)
tree5172bfbe4df60948bf6d61ebea28366a51c03c12 /src/helper/Makefile.am
parent104580e0bfb5aa2f79bc6c4c96935a8832f5f787 (diff)
downloadopenocd+libswd-647e61cc6d9b13dd2799d2302ce9289a1627e36c.tar.gz
openocd+libswd-647e61cc6d9b13dd2799d2302ce9289a1627e36c.tar.bz2
openocd+libswd-647e61cc6d9b13dd2799d2302ce9289a1627e36c.tar.xz
openocd+libswd-647e61cc6d9b13dd2799d2302ce9289a1627e36c.zip
Extend autotools build to create shared library libopenocd with libtool:
- Add libtoolize step too bootstrap script; creates ltmain.sh script. - Add AC_PROG_LIBTOOL to configure.in to add libtool support to build. - Change Makefile.am library rules from static (_a) to libtool (_la). - Install libopenocd.{la,so,a} in $(libdir); update openocd link rules. - Extend MAINTAINERCLEANFILES in top-level Makefile.am to remove ltmain.sh. git-svn-id: svn://svn.berlios.de/openocd/trunk@1695 b42882b7-edfa-0310-969c-e2dbd0fdcd60
Diffstat (limited to 'src/helper/Makefile.am')
-rw-r--r--src/helper/Makefile.am10
1 files changed, 5 insertions, 5 deletions
diff --git a/src/helper/Makefile.am b/src/helper/Makefile.am
index afe26b81..a5582783 100644
--- a/src/helper/Makefile.am
+++ b/src/helper/Makefile.am
@@ -5,7 +5,7 @@ AM_CPPFLAGS = \
-DPKGLIBDIR=\"$(pkglibdir)\"
METASOURCES = AUTO
-noinst_LIBRARIES = libhelper.a
+noinst_LTLIBRARIES = libhelper.la
if ECOSBOARD
CONFIGFILES =
@@ -15,19 +15,19 @@ endif
-libhelper_a_SOURCES = \
+libhelper_la_SOURCES = \
binarybuffer.c $(CONFIGFILES) configuration.c \
log.c command.c time_support.c \
replacements.c fileio.c startup_tcl.c
if IOUTIL
-libhelper_a_SOURCES += ioutil.c
+libhelper_la_SOURCES += ioutil.c
endif
-libhelper_a_CFLAGS =
+libhelper_la_CFLAGS =
if IS_MINGW
# FD_* macros are sloppy with their signs on MinGW32 platform
-libhelper_a_CFLAGS += -Wno-sign-compare
+libhelper_la_CFLAGS += -Wno-sign-compare
endif
noinst_HEADERS = binarybuffer.h configuration.h types.h log.h command.h \