summaryrefslogtreecommitdiff
path: root/src/helper/Makefile.am
diff options
context:
space:
mode:
authorzwelch <zwelch@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2009-05-10 19:44:38 +0000
committerzwelch <zwelch@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2009-05-10 19:44:38 +0000
commit72acdac71aa2b2dd787f9b1e400d058e1887e61f (patch)
treea48684c54312c525c5b7c2ef9b43866271bf6bd2 /src/helper/Makefile.am
parent90465379e558ea7310867d9d39b79428c2050ddb (diff)
downloadopenocd+libswd-72acdac71aa2b2dd787f9b1e400d058e1887e61f.tar.gz
openocd+libswd-72acdac71aa2b2dd787f9b1e400d058e1887e61f.tar.bz2
openocd+libswd-72acdac71aa2b2dd787f9b1e400d058e1887e61f.tar.xz
openocd+libswd-72acdac71aa2b2dd787f9b1e400d058e1887e61f.zip
Revive tclapi.c from r1650:
* Remove superfluous #include directives. * Fix warnings and API usage to cure its bit rot. * Build into libhelper library (for now). Add tclapi.h to export tclapi_register_commands(). Register tclapi commands in openocd.c:setup_command_handler(). git-svn-id: svn://svn.berlios.de/openocd/trunk@1691 b42882b7-edfa-0310-969c-e2dbd0fdcd60
Diffstat (limited to 'src/helper/Makefile.am')
-rw-r--r--src/helper/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/helper/Makefile.am b/src/helper/Makefile.am
index e0686401..5926f658 100644
--- a/src/helper/Makefile.am
+++ b/src/helper/Makefile.am
@@ -15,7 +15,9 @@ endif
-libhelper_a_SOURCES = binarybuffer.c $(CONFIGFILES) configuration.c log.c command.c time_support.c \
+libhelper_a_SOURCES = \
+ binarybuffer.c $(CONFIGFILES) configuration.c \
+ log.c command.c time_support.c tclapi.c \
replacements.c fileio.c startup_tcl.c
if IOUTIL